• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: ntpdate doesn't see servers  (Read 10066 times)
elBradford
Newbie
*

Karma: 0
Posts: 44


View Profile
« on: April 17, 2009, 11:34:44 AM »

Hello,

I looked at the relevant article in the wiki, however it doesn't seem to be a problem with my nameserver (I can ping out just fine). The ntp servers are supposed to be listed in /etc/ntp.conf, however this file doesn't exist. What does exist is /etc/default/ntpdate. This file has its own list of ntp servers (one actually, ntp.ubuntu.com) that it is supposed to use if /etc/ntp.conf doesn't exist.

So, the command ntpdate just returns

Code:
root@debian:~# ntpdate
17 Apr 18:33:34 ntpdate[1732]: no servers can be used, exiting

whereas I can explicitly give the command a server and it works fine

Code:
root@debian:~# ntpdate ntp.ubuntu.com
17 Apr 18:34:14 ntpdate[1734]: adjust time server 91.189.94.4 offset 0.018658 sec

Funny. Does anyone have this problem?
Logged

rcm89
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #1 on: April 17, 2009, 02:41:25 PM »

The manpage for ntpdate(1) http://manpages.ubuntu.com/manpages/dapper/en/man1/ntpdate.1.html shows the server name as being required.  That's the way I've always seen it since the dark ages...

Also ntpdate seems to have been deprecated in the last few years...it disappeared after Ubuntu 6.06LTS. The FreeBSD 7.x manpage lists it in a state of mourning, being replaced by ntpd -q [but the Linux ntpd does not list -q as an option].
Logged

--Ron

elBradford
Newbie
*

Karma: 0
Posts: 44


View Profile
« Reply #2 on: April 19, 2009, 02:38:13 AM »

I've taken the easy way out. I have webmin installed, and used the gui there to set up an hourly time sync of the sofware and hardware clocks to ntp.ubuntu.com. Smiley
Logged

Pages: [1]
Print
Jump to: