• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Coherence Media Server question  (Read 1904 times)
jdonth
Jr. Member
**

Karma: 0
Posts: 75

Azle, Texas


View Profile
« on: November 11, 2009, 10:42:51 AM »

I have installed the Coherence Media Server on my Plug.

It is working (I can play media files on my Popcorn Hour player) but I am getting errors in the log file and am wondering if I still have a problem and don't know it.

Thanks,
Joe

My conf file (without most of the commented-out fields) is:
Code:
# config file for coherence
logmode = warning                         # none, error, warning, info, debug, log
logfile = /var/log/coherence.log
serverport = 30020                       # if not specified or set to 0
controlpoint = yes                        # if set to yes coherence will activate its
web-ui = no                               # set this to yes to enable some interactive
use_dbus = yes                            # set this to yes to let Coherence signal

[subsystem_log]
#coherence = info
#WebUI = info
#SSDP = info
#MSEARCH = info
#SOAP = info
#Action = info
#Variable = info
#Event = info
#Service_Server = info
#Service_Client = info
#Device = info
#Connection_Manager_Server = info
#MediaServer= info
#MediaRenderer= log
#ControlPoint = info
#MS_Client = info
#flickr_storage = info
#Buzztard=info

[plugins]
 [[FSStore]]
  content = /media/Shows
  name = Coherence - HDHR media

and the log file is:
Code:
WARN  coherence                   Nov 11 17:35:18  Coherence UPnP framework shutdown (coherence/base.py:504)
Unhandled error in Deferred:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/coherence/upnp/core/utils.py", line 449, in handleResponse
    self.factory.page(response)
  File "/usr/lib/python2.6/dist-packages/coherence/upnp/core/utils.py", line 503, in page
    self.deferred.callback((page, self.response_headers))
  File "/usr/lib/python2.6/dist-packages/twisted/internet/defer.py", line 243, in callback
    self._startRunCallbacks(result)
  File "/usr/lib/python2.6/dist-packages/twisted/internet/defer.py", line 312, in _startRunCallbacks
    self._runCallbacks()
--- <exception caught here> ---
  File "/usr/lib/python2.6/dist-packages/twisted/internet/defer.py", line 328, in _runCallbacks
    self.result = callback(self.result, *args, **kw)
  File "/usr/lib/python2.6/dist-packages/coherence/upnp/core/device.py", line 376, in gotPage
    self.parse_device(d) # root device
  File "/usr/lib/python2.6/dist-packages/coherence/upnp/core/device.py", line 253, in parse_device
    eventSubUrl, presentationUrl, scpdUrl, self))
  File "/usr/lib/python2.6/dist-packages/coherence/upnp/core/service.py", line 77, in __init__
    self.parse_actions()
  File "/usr/lib/python2.6/dist-packages/coherence/upnp/core/service.py", line 376, in parse_actions
    utils.getPage(self.get_scpd_url()).addCallbacks(gotPage, gotError, None, None, [self.get_scpd_url()], None)
  File "/usr/lib/python2.6/dist-packages/coherence/upnp/core/service.py", line 224, in get_scpd_url
    return self.device.make_fullyqualified(self.scpd_url)
  File "/usr/lib/python2.6/dist-packages/coherence/upnp/core/device.py", line 390, in make_fullyqualified
    if base[-1] != '/':
exceptions.IndexError: string index out of range
WARN  coherence                   Nov 11 17:35:20  Coherence UPnP framework version 0.6.2 starting... (coherence/base.py:275)
WARN  webserver                   Nov 11 17:35:20  WebServer on port 30020 ready (coherence/base.py:110)
WARN  plugins                     Nov 11 17:35:20  Can't load plugin MiroStore (No module named gdata.youtube.service), maybe missing dependencies... (coherence/base.py:169)
WARN  plugins                     Nov 11 17:35:20  Can't load plugin YouTubeStore (No module named gdata.youtube.service), maybe missing dependencies... (coherence/base.py:169)
WARN  plugins                     Nov 11 17:35:20  Can't load plugin ITVStore (No module named gdata.youtube.service), maybe missing dependencies... (coherence/base.py:169)
/usr/lib/python2.6/dist-packages/coherence/backends/lastfm_storage.py:38: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
WARN  plugins                     Nov 11 17:35:20  Can't load plugin TrackerStore (No module named dbus), maybe missing dependencies... (coherence/base.py:169)
WARN  plugins                     Nov 11 17:35:20  Can't load plugin DVBDStore (No module named dbus), maybe missing dependencies... (coherence/base.py:169)
WARN  coherence                   Nov 11 17:35:21  Unable to activate dbus sub-system: ImportError('No module named dbus',) (coherence/base.py:370)
WARN  mediaserver                 Nov 11 17:35:22  Coherence - HDHR media MediaServer (FSStore'>) activated with 84a52111-3003-49c1-9b9e-dea2970f7a1c (coherence/upnp/devices/media_server.py:601)

Logged

...I've always depended on the kindness of strangers

Pages: [1]
Print
Jump to: