• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: How do I update the MAC address ?  (Read 3051 times)
mail4asim
Newbie
*

Karma: 0
Posts: 39



View Profile
« on: November 08, 2009, 03:46:22 PM »

I recently used installed 1.0 and forgot to change the MAC address in the custom u-boot file.  Is there a simple way to change my MAC address ?

Logged

emstester
Newbie
*

Karma: 1
Posts: 24


View Profile
« Reply #1 on: November 08, 2009, 08:24:40 PM »

try
Code:
setenv ethaddr yourmacaddress
then
Code:
saveenv
to save it to nand and verfy using printenv ethaddr

note: you need to do this at uboot prompt Marvell>>
« Last Edit: November 08, 2009, 10:01:38 PM by emstester » Logged

jdonth
Jr. Member
**

Karma: 0
Posts: 75

Azle, Texas


View Profile
« Reply #2 on: November 09, 2009, 07:50:41 AM »

To change the MAC address after your system is up and running:

echo "hwaddress ether 00:50:43:00:00:00" >> /etc/network/interfaces
/etc/init.d/networking restart

Replace 00:50:43:00:00:00 with your MAC address.
Logged

...I've always depended on the kindness of strangers

birdman
Sr. Member
****

Karma: 4
Posts: 443


View Profile WWW
« Reply #3 on: November 09, 2009, 05:51:12 PM »

try
Code:
setenv ethaddr yourmacaddress
Doesn't work.  Tried that when I forgot to do it.  Setting in /etc/network/interfaces will work.  Then remember to edit the config file before the next(?) installer run.
Logged

emstester
Newbie
*

Karma: 1
Posts: 24


View Profile
« Reply #4 on: November 09, 2009, 06:20:10 PM »

try
Code:
setenv ethaddr yourmacaddress
Doesn't work.  Tried that when I forgot to do it.  Setting in /etc/network/interfaces will work.  Then remember to edit the config file before the next(?) installer run.
it will not work if you are already at the ubuntu, try to stop the autoboot at the start.
Logged

fragfutter
Sr. Member
****

Karma: 12
Posts: 280


View Profile
« Reply #5 on: November 10, 2009, 03:58:21 AM »

it might also not work inside the u-boot prompt. The environment variables ethaddr are write once (default u-boot, not tested with the version of the sheevaplug)
Logged

birdman
Sr. Member
****

Karma: 4
Posts: 443


View Profile WWW
« Reply #6 on: November 10, 2009, 06:13:26 PM »

it will not work if you are already at the ubuntu, try to stop the autoboot at the start.
It doesn't work at the uboot prompt.  That's what I tried when I forgot.  There was a warning somehwre on this Wiki that it might not (well, the warning was that it would not) work, but I tried anyway - and failed.  But since I could set it from the OS anyway I didn't really mind - coupled with the fact that it's on a small private network anyway.,..
Logged

snake
Newbie
*

Karma: 3
Posts: 37



View Profile
« Reply #7 on: November 10, 2009, 09:55:46 PM »

it will not work if you are already at the ubuntu, try to stop the autoboot at the start.
It doesn't work at the uboot prompt.  That's what I tried when I forgot.  There was a warning somehwre on this Wiki that it might not (well, the warning was that it would not) work, but I tried anyway - and failed.  But since I could set it from the OS anyway I didn't really mind - coupled with the fact that it's on a small private network anyway.,..

Try using "set" instead of "setenv" for setting the ethaddr value in the u-boot prompt. You could immediately check whether the ethaddr parameter has changed by using "printenv ethaddr" then save the value by issuing "saveenv".

>>set ethaddr <MAC Address>
>>printenv ethaddr
>>saveenv


Works in my set-up.  Wink


Logged

guidol
Full Member
***

Karma: 10
Posts: 128



View Profile
« Reply #8 on: November 09, 2010, 02:26:33 PM »

>>set ethaddr <MAC Address>
>>printenv ethaddr
>>saveenv
Works in my set-up.  Wink

Many Thanks for that Info....I got self changing MAC-Addresses because I did use setenv instead of set (and saveenv)
WRONG : setenv ethaddr=XX:XX:XX:XX
RIGHT: set ethaddr XX:XX:XX:XX
Logged

Pages: [1]
Print
Jump to: