• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: MP3 Audio Player - Airtunes Lite  (Read 1690 times)
darkscout
Newbie
*

Karma: 0
Posts: 26


View Profile
« on: October 31, 2009, 09:58:27 AM »

Cleaning the house I came across my old Griffin iMic, which has to be one of the earliest USB soundcards. I bought it 2001-ish to import records on my Mac.

Plugged in, installed ALSA,

Code:
plug:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: system [iMic USB audio system], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Code:
plug:~# aplay -L
default:CARD=system
    iMic USB audio system, USB Audio
    Default Audio Device
front:CARD=system,DEV=0
    iMic USB audio system, USB Audio
    Front speakers
surround40:CARD=system,DEV=0
    iMic USB audio system, USB Audio
    4.0 Surround output to Front and Rear speakers
surround41:CARD=system,DEV=0
    iMic USB audio system, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=system,DEV=0
    iMic USB audio system, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=system,DEV=0
    iMic USB audio system, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=system,DEV=0
    iMic USB audio system, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=system,DEV=0
    iMic USB audio system, USB Audio
    IEC958 (S/PDIF) Digital Audio Output
null
    Discard all samples (playback) or generate zero samples (capture)

Alsamixer shows 4 controls:
Bass, Bass Boost, Treble, PCM.

Cranked up PCM. If you unmute Bass Boost, it does what you expect. As do Bass and Treble.

Code:
plug:~# mplayer Trance\ June\ 2007.mp3
MPlayer SVN-r29789 (C) 2000-2009 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Trance June 2007.mp3.
Audio only file format detected.
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 64.0 kbit/4.54% (ratio: 8000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video

No config other than unmuting alsa.

With PulseAudio it should be trivial to set up streaming to it.

However all my music is on drives connected to the Plug, so no reason to for me.


« Last Edit: October 31, 2009, 10:45:47 AM by darkscout » Logged

Pages: [1]
Print
Jump to: