• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Completely Blank Console  (Read 2110 times)
Hodcon
Newbie
*

Karma: 0
Posts: 5


View Profile
« on: October 22, 2009, 07:34:13 AM »

Hi all,

OK first post so please bear with me. I've had a look around and haven't been able to track down anyone with the same problem, or at least not that I've been able to interpret.

Long and short, my sheevaplug doesn't boot anymore. I.e, the console is completely blank! It doesn't even get to the inital "512MB" bit, or at least not that I can see.

Bit of backgroud: I may potentially have done something very stupid, hypothetically speaking of course _
I got it out of the box, and fired it up. Managed to get in to the default install of ubuntu via SSH. I was very psyched. I then set about doing an "aptitude -y dist-upgrade". Yes, that's right, I updated everything with out setting up a new users first (I usually run debian, so such a step wouldn't normally have been a problem. I could just log back in as root).

Which of course means, that after a reboot, I couldn't log in anymore!

What followed was a downward spiral of events, which started at a "resetenv" from the console, and ended in me installing a TFTP server elsewhere and trying to boot from that. Which kind of worked, but just got stuck at "......Booting Linux kernel".

I may have also tried to apply some filth hax by reflashing the NAND, which of course (being a n00b), I completely screwed up. Sad

So there we have it, my Sheevaplug no longer boots, at all. I can't even get in to the Marvell>> console.

Is there anyway of getting back from this?? I really want to get this sheeva plug working, it's an awesome bit of kit.

What I'm thinking is, is there any way of flashing the NAND with a new image?? I also haven't been able to get the runme.exe OR runme.php working, as I get a:


 ****   Burning uboot and environment variables ... This will take few minutes ...
sh: openocd/openocd: No such file or directory
 ****   openocd FAILED
 ****   Is the mini USB cable connected?
 ****   Try powering down, then replugging the Sheevaplug

btw, that's from both a Windows and Debian machine.

ANY help would be appreciated!!

Logged

restamp
Global Moderator
Sr. Member
*****

Karma: 4
Posts: 273


View Profile
« Reply #1 on: October 22, 2009, 10:32:00 AM »

Try running the SheevaPlug installer.  You can find the instructions at:

http://www.openplug.org/plugwiki/index.php/SheevaPlug_Installer
Logged

Hodcon
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #2 on: October 22, 2009, 10:39:31 AM »

As it happens, I was just downloading the tarball! I'll post my findings afterwards.
Logged

Hodcon
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #3 on: October 22, 2009, 02:10:21 PM »

OK, so I'e been working through this guide now a couple of times and always get stuck at the same stumbling block! (In Windows XP 64bit and Debian). Can anyone help me out on the following output???


C:\Documents and Settings\Administrator\Desktop\New Folder (2)>runme.exe nand
 ****   Preparing environment variables file ...
reading uboot\uboot-env\uboot-dflt.txt
uboot\uboot-env\fw_setenv.exe baudrate 115200
CRC read error on uboot-env.bin: No error
uboot\uboot-env\fw_setenv.exe loads_echo 0
uboot\uboot-env\fw_setenv.exe ipaddr 10.4.50.165
uboot\uboot-env\fw_setenv.exe serverip 10.4.50.5
uboot\uboot-env\fw_setenv.exe rootpath /mnt/ARM_FS/
uboot\uboot-env\fw_setenv.exe netmask 255.255.255.0
uboot\uboot-env\fw_setenv.exe stdin serial
uboot\uboot-env\fw_setenv.exe stdout serial
uboot\uboot-env\fw_setenv.exe stderr serial
uboot\uboot-env\fw_setenv.exe console console=ttyS0,115200 mtdparts=nand_mtd:0xc
0000@0(uboot)ro,0x1ff00000@0x100000(root)
uboot\uboot-env\fw_setenv.exe mainlineLinux no
uboot\uboot-env\fw_setenv.exe CASset min
uboot\uboot-env\fw_setenv.exe enaMonExt no
uboot\uboot-env\fw_setenv.exe enaCpuStream no
uboot\uboot-env\fw_setenv.exe enaWrAllo no
uboot\uboot-env\fw_setenv.exe pexMode RC
uboot\uboot-env\fw_setenv.exe disL2Cache no
uboot\uboot-env\fw_setenv.exe setL2CacheWT yes
uboot\uboot-env\fw_setenv.exe disL2Prefetch yes
uboot\uboot-env\fw_setenv.exe enaICPref yes
uboot\uboot-env\fw_setenv.exe enaDCPref yes
uboot\uboot-env\fw_setenv.exe sata_dma_mode yes
uboot\uboot-env\fw_setenv.exe MALLOC_len 1
uboot\uboot-env\fw_setenv.exe ethprime egiga0
uboot\uboot-env\fw_setenv.exe netbsd_en no
uboot\uboot-env\fw_setenv.exe vxworks_en no
uboot\uboot-env\fw_setenv.exe bootargs_root root=/dev/nfs rw
uboot\uboot-env\fw_setenv.exe bootargs_end :::DB88FXX81:eth0:none
uboot\uboot-env\fw_setenv.exe image_name uImage
uboot\uboot-env\fw_setenv.exe bootcmd tftpboot 0x2000000 $(image_name);setenv bo
otargs $(console) $(bootargs_root) nfsroot=$(serverip):$(rootpath) ip=$(ipaddr):
$(serverip)$(bootargs_end) $(mvNetConfig) $(mvPhoneConfig);  bootm 0x2000000;
uboot\uboot-env\fw_setenv.exe standalone fsload 0x2000000 $(image_name);setenv b
ootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end
) $(mvPhoneConfig); bootm 0x2000000;
uboot\uboot-env\fw_setenv.exe bootdelay 3
uboot\uboot-env\fw_setenv.exe disaMvPnp no
uboot\uboot-env\fw_setenv.exe ethaddr 00:50:43:4e:2a:14
uboot\uboot-env\fw_setenv.exe ethmtu 1500
uboot\uboot-env\fw_setenv.exe mvPhoneConfig mv_phone_config=dev0:fxs,dev1:fxs
uboot\uboot-env\fw_setenv.exe mvNetConfig mv_net_config=(00:11:88:0f:62:81,0:1:2
:3),mtu=1500
uboot\uboot-env\fw_setenv.exe usb0Mode host
uboot\uboot-env\fw_setenv.exe yuk_ethaddr 00:00:00:EE:51:81
uboot\uboot-env\fw_setenv.exe nandEcc 1bit
uboot\uboot-env\fw_setenv.exe netretry no
uboot\uboot-env\fw_setenv.exe rcvrip 169.254.100.100
uboot\uboot-env\fw_setenv.exe loadaddr 0x02000000
uboot\uboot-env\fw_setenv.exe autoload no
uboot\uboot-env\fw_setenv.exe enaAutoRecovery yes
uboot\uboot-env\fw_setenv.exe ethact egiga0
reading uboot\uboot-env\uboot-nand-custom.txt
uboot\uboot-env\fw_setenv.exe bootargs_root ubi.mtd=1 root=ubi0:rootfs rootfstyp
e=ubifs
uboot\uboot-env\fw_setenv.exe mtdpartitions mtdparts=orion_nand:0x400000@0x10000
0(uImage),0x1fb00000@0x500000(rootfs)
uboot\uboot-env\fw_setenv.exe ethaddr 00:50:43:01:63:5e
uboot\uboot-env\fw_setenv.exe real_bootcmd setenv bootargs $(bootargs_console) $
(mtdpartitions) $(bootargs_root); nand read.e 0x00800000 0x00100000 0x00400000;
bootm 0x00800000
uboot\uboot-env\fw_setenv.exe bootargs_console console=ttyS0,115200
uboot\uboot-env\fw_setenv.exe bootcmd run recover1
uboot\uboot-env\fw_setenv.exe recover1 setenv mainlineLinux yes; setenv arcNumbe
r 2097; setenv bootcmd run recover2; saveenv; reset
uboot\uboot-env\fw_setenv.exe recover2 run recover3; setenv bootcmd $(real_bootc
md); saveenv; setenv bootargs $(bootargs_console) $(mtdpartitions) root=/dev/ram
0 rw ramdisk=0x01100000,8M install_type=nand; bootm 0x00800000 0x01100000
uboot\uboot-env\fw_setenv.exe recover3 run recover4; nand erase clean 0x00100000
 0x00400000; nand write.e 0x00800000 0x00100000 0x00400000
uboot\uboot-env\fw_setenv.exe recover4 usb start; fatload usb 0 0x00800000 uImag
e; fatload usb 0 0x01100000 initrd

 ****   Burning uboot and environment variables ... This will take few minutes .
..
 ****   When uboot.bin is written to NAND/SD, Disconnect and connect your mini U
SB cable
Open On-Chip Debugger 0.2.0 (2009-07-27-16:41) Release
$URL: http://svn.berlios.de/svnroot/repos/openocd/tags/openocd-0.2.0/src/openocd
.c $
For bug reports, read http://svn.berlios.de/svnroot/repos/openocd/trunk/BUGS
2000 kHz
jtag_nsrst_delay: 200
jtag_ntrst_delay: 200
dcc downloads are enabled
Error: unable to open ftdi device: device not found
Runtime error, file "command.c", line 469:
     ****       openocd FAILED
 ****   Is the mini USB cable connected?
 ****   Try powering down, then replugging the Sheevaplug
C:\Documents and Settings\Administrator\Desktop\New Folder (2)>


Any thoughts would be GRATEFULLY received! I've completely run out of ideas!
Logged

snake
Newbie
*

Karma: 3
Posts: 37



View Profile
« Reply #4 on: October 23, 2009, 02:32:26 AM »


Any thoughts would be GRATEFULLY received! I've completely run out of ideas!


Maybe this could help you, based on how I do it in the "windows" version of the sheevaplug-installer. I know you are already familiar with the basic instructions but I just added some things.

Please, also take note that I am using Teraterm as the serial console.
I have also installed the USBtoSerial JTAG driver (FTDI) on my windows PC.


1. Connect the USB stick (preloaded with installer) into the Plugcomputer.
2. Attach the JTAG into the plugcomputer and connect it to the PC using USB cable.
3. Supply power to the plugcomputer unit.
*4. When the plugcomputer boots up, disconnect and reconnect the USB cable of the JTAG.
5. Execute "runme.exe | nand" on the command prompt, this will format the NAND flash.
*6. After the nand is formatted through open ocd, close the CMD prompt. Disconnect and reconnect the USB cable of the JTAG.
7. Open teraterm and select the appropriate serial port. Configure Baud rate to 115200.
8. Wait until the rootfilesystem is flashed into the NAND and the system reboots.


Oftentimes, I have to disconnect and reconnect the usb cable of the JTAG board just to make it work on windows.  Grin


Hope this could help.
Logged

Hodcon
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #5 on: October 23, 2009, 03:32:08 AM »

Hi snake, thanks for your help on this one. It's very much appreciated!  I've tried a number of variations here and I always seem to get stuck at the same stumbling block!

Error: unable to open ftdi device: device not found
Runtime error, file "command.c", line 469:
     ****       openocd FAILED
 ****   Is the mini USB cable connected?
 ****   Try powering down, then replugging the Sheevaplug


The most interesting line of which is this:

Error: unable to open ftdi device: device not found


Now, I've been over a few things here to make sure that I haven't missed anything:

  • I've checked that firstly the drivers for the JTAG are installed correctly, which they appear to be
  • Ive checked that the vendor/product ID's are correct (useing USBDevice), which they seem to be
  • I've checked that the serial convertion is ok. I have 2 USB Converters (A and B) both of which are loading the COM ports (COM3 and COM4)
  • I can connect to both of the COM ports at 115200 but am still presented with a blank screen on both and it will accept any input. That's using both PuTTY and HyperTerminal (I haven't tried TeraTerm, although, I'm not sure it would make much difference as I get the same behaviour from a "cu -s 115200 -l /dev/ttyUSB0" on a debian box)

I can't help but feel that some part of me is screaming "USE A 32 BIT XP YOU FOOL!". I'm intending on trying this tonight, when I get home. I don't know if XP 64bit (which is what I'm running) does stupid things with USB to serial converters or USB devices, etc. And I'm running an AMD64 bit kernel on my debian box.

I'm trying desperately not to lose hope here. I refuse to accept that there isn't a way to get this thing back up and running again.

Thanks again for any help you can give me, even if it doesn't solve the problem directly, it might give me new avenues to explore!
Logged

boerner
Jr. Member
**

Karma: 0
Posts: 54


View Profile
« Reply #6 on: October 23, 2009, 09:20:52 AM »

Just throwing my own two cents in...

Have you tried checking the usb cable itself and maybe trying a different one? Many people have had issues with the cable coming loose or not connecting securely. I didn't have the issue with my plug, but another one I setup had a 'loose' connector. Swapping the cable solved my issue there.

Just a thought :-)
Logged

Reedy
Newbie
*

Karma: 0
Posts: 40


View Profile
« Reply #7 on: October 23, 2009, 11:44:39 AM »

http://plugcomputer.org/plugforum/index.php?topic=717.0

Contains various fixes for these issues!
Logged

Hodcon
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #8 on: October 25, 2009, 03:05:08 PM »

THANK YOU GOD! THANK YOU FOR 32BIT OPERATING SYSTEMS!!!

And thanks to everyone so far that helped. I've been away all weekend, hense the late reply. Happened to have a 32 bit XP laptop lying around, so I tryed the install procedure on that, which is running through as I type. Hopefully it'll finish ok. I'll keep you all updated.

OPENOCD DOES NOT WORK ON XP 64 BIT!
Logged

Pages: [1]
Print
Jump to: