• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Help using DVB - Hauppauge WinTV NOVA-TD USB2  (Read 1951 times)
dvbuser
Newbie
*

Karma: 0
Posts: 5


View Profile
« on: September 21, 2009, 02:05:01 PM »

I've been trying to get a Hauppauge WinTV NOVA-TD USB2 stick to work with the SheevaPlug with little success.

After trying to compile my own kernel, I've resorted to the http://sheeva.with-linux.com/sheeva/ kernels. Although these install sucessfully, I am still unable to use my DVB stick

If I enter lsusb, I get:

root@debian:/usr/include# lsusb
Bus 001 Device 006: ID 2040:5200 Hauppauge
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@debian:/usr/include#

However lsmod or dmesg return nothing in relation to dvb or the device.

With this in mind, I then tried compiling v4l. Unfortunately I keep getting the following errors:

root@debian:/v4l-dvb# make
make -C /v4l-dvb/v4l
make[1]: Entering directory `/v4l-dvb/v4l'
Updating/Creating .config
Preparing to compile for kernel version 2.6.31
File not found: /lib/modules/2.6.31/build/.config at ./scripts/make_kconfig.pl line 32, <IN> line 4.
make[1]: *** No rule to make target `.myconfig', needed by `config-compat.h'.  Stop.
make[1]: Leaving directory `/v4l-dvb/v4l'
make: *** [all] Error 2
root@debian:/v4l-dvb#

I believe that this is due to missing headers.

I have tried to download and untar the linux headers from http://sheeva.with-linux.com/sheeva/ but I'm not sure where the directory structure should be untared to.

So, I guess this leaves with me with two questions:

1. Can anybody tell me how to get DVB working with the Hauppauge WinTV NOVA-TD USB2 on the Sheeva Plug?

2. How do I get the headers installed correctly to allow v4l to make correctly?

Thanks
Logged

nephilim1973
Newbie
*

Karma: 0
Posts: 17


View Profile
« Reply #1 on: September 21, 2009, 05:09:37 PM »

I'm trying to get my Pinnacle Dazzle DVC 100 to work, too.
It's an USB-device.

My topic "vl4-support needed" in the kernel section was deleted...   :-(

Though I try to compile my own version of kernel.

With 2.6.31, I have the same issues like you.

With my first self-compiled kernel, the video-adapter is working !
But I have missed some network options. I couldn't stream the signal to internet via VLC.

My second kernel isn't booting... :-(

Now I am searching for the bug...

If the issue is resolved, I could send you my "uImage" with drivers for our video-adapters...

No problem.

Please look at

http://plugcomputer.org/plugforum/index.php?topic=693.0

for progress.

Best regards
Nephilim
« Last Edit: September 21, 2009, 05:18:53 PM by nephilim1973 » Logged

Pages: [1]
Print
Jump to: