• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: PPTP VPN Server  (Read 13212 times)
riel
Newbie
*

Karma: -2
Posts: 22


View Profile
« on: September 01, 2009, 06:36:44 PM »

As I was deperatedly trying to setup a VPN server with relatively easy acces on windows machines, I always use PPTP server for it.

But I couldn't get it running at first.

I use Webmin to set up the server, setting up pptp is not very hard, but on sheevaplug (with my kernel 2.6.30.5) you run into issues:

> apt-get install pptpd ppp

I believe it automatically defaults to MPPE auth. But you need to disable this!
Since: MPPE requires support in both the PPP daemon and operating system kernel. --> we dont have it

Second is we are still coping with this bug:

https://bugs.launchpad.net/ubuntu/jaunty/+source/pptpd/+bug/352622

Commenting #logwtmp in /etc/pptpd.conf did the trick, as described.

Now, pptp VPN is working!


I also had the issue that pppd wasn't executable, but think a re-isntall fixed it. Check it if it is still not working?




« Last Edit: September 01, 2009, 06:43:02 PM by riel » Logged

Ash
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #1 on: January 06, 2010, 02:13:09 PM »

Hi,

I got this working with MPPE by upgrading the kernel and building in MPPE support from menuconfig - works like a charm.

Ash
Logged

xoxox
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #2 on: February 22, 2010, 10:42:11 AM »

Hi ash , could you please describe how to compile the new kernel?

I currently running the prebuilt 2.6.32.8 kernel  from http://sheeva.with-linux.com on a SD-Card.

I tried to compile a new kernel with the prebuilt config with MPPE and the sources from kernel.org directly on the plug. The kernel compiled without problems, but i have massive problems with the modules.

Edit: Ok, i've managed to built the modules. Cleared everything, got new kernel-sources, copied the the  sheeva-2.6.32.8.config to .config, changed "CONFIG_PPP_MPPE is not set" to "CONFIG_PPP_MPPE=m, make modules, make modules_install, reboot, depmod -a

Then i added these modules to /etc/modules ppp_generic, ppp_async, ppp_mppe, sha1, ppp_deflate

I have a FritzBox Router running a poptop server and an iPod Touch as Client. I'm using the same options as in the FritzBox, but i can't get an encrypted connection, an unencrypted connection works perfectly.

For encryption i use the following parameters in /etc/ppp/pptpd-options
refuse-pap
refuse-chap
refuse-mschap
refuse-eap
require-mppe

But i always get the standard error message: LCP terminated by peer (MPPE required but peer negotiation failed) :-(

I tried to follow http://pptpclient.sourceforge.net/howto-diagnosis.phtml#mppe_rbpnf but no success.
Deactivating the encryption is not really an option, on the iPhone i've set "Encryption" to "Automatic" and also tried "Maximum", but it didn't help.
With the FritzBox as server "Automatic" works, so i don't think it's a client problem

Could you please post your pptpd-options and  pptpd.conf?

Edit2: Ok, i'm gone wild. I deleted all the ***** configs and started over. Now it works, don't ask why...
Here are my configs:
/etc/pptpd.conf
Code:
option /etc/ppp/pptpd-options
localip 192.168.6.8
remoteip 192.168.6.234-238
/etc/ppp/pptpd-options
Code:
name PPTP
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
require-mppe-128
proxyarp
nodefaultroute
lock
nobsdcomp



« Last Edit: February 24, 2010, 10:13:19 AM by xoxox » Logged

Pages: [1]
Print
Jump to: