• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: U-Boot not responding to keyboard input (solved)  (Read 9484 times)
1abc2
Newbie
*

Karma: 0
Posts: 11


View Profile
« on: August 21, 2009, 11:41:00 AM »

Hi.
I am trying to stop the autoboot of U-Boot. I tried this on different pcs, distributions and with different terminal software (kermit, minicom). I even updated the U-Boot of my Sheevaplug using the Sheevaplug Installer. But, I can't stop the autoboot. Can somebody help me, please?

Code:
root@sidux:/home/sidux# kermit -l /dev/ttyUSB1 -b 115200
C-Kermit 8.0.211, 10 Apr 2004, for Linux
 Copyright (C) 1985, 2004,
  Trustees of Columbia University in the City of New York.
Type ? or HELP for help.
(/home/sidux/) C-Kermit>c
Connecting to /dev/ttyUSB1, speed 115200
 Escape character: Ctrl-\ (ASCII 28, FS): enabled
Type the escape character followed by C to get back,
or followed by ? to see other options.
----------------------------------------------------
 Done
NAND:512 MB

CPU : Marvell Feroceon (Rev 1)

Streaming disabled
Write allocate disabled


USB 0: host mode
PEX 0: interface detected no Link.
Net:   egiga0 [PRIME], egiga1
Hit any key to stop autoboot:  0

NAND read: device 0 offset 0x100000, size 0x400000

Reading data from 0x4ff800 -- 100% complete.
 4194304 bytes read: OK
## Booting image at 00800000 ...
Bad Magic Number
Marvell>>
« Last Edit: August 28, 2009, 03:13:01 PM by 1abc2 » Logged

Ann Onemouse
Newbie
*

Karma: 0
Posts: 12


View Profile
« Reply #1 on: August 21, 2009, 12:12:02 PM »

I can think of three things that might be wrong:

1) Something wrong with the serial connection on the PC end. This seems unlikely, as you've tried different software, and presumably the output you've pasted was seen from both.

2) Something wrong with the serial connection on the Sheeva (firmware setting like parity, etc.?). You should be able to reset all this stuff using the alpha6 installer (search these forums -- you can't miss it), which resets all uboot settings. Of course, there could be a real hardware problem with your plug.

3) Something wrong with the serial cable, or a loose connection.

To distinguish among these various possibilities, I would first answer the following: have you ever had the device working correctly, serial connection and all? (I notice that it's not booting fully in your pasted output.) If you had it working before, and changed nothing regarding the hardware or PC settings, you can probably rule out #1 and #3, above.

Then learn how to use the alpha6 installer. This will serve you well in all future experimentation anyway, and if the problem is with some device setting, it will be fixed right away. If that doesn't fix it, and the problem persists across multiple host PCs and mini-USB cables, then I'd guess something broken with the plug hardware. It's weird to get all that serial output faithfully, though, with no control -- especially the '0' character right after "Hit any key to stop autoboot", which I presume YOU typed, and was echoed back by the plug. That indicates correct, full-duplex serial connectivity.

-Ann



Logged

restamp
Global Moderator
Sr. Member
*****

Karma: 4
Posts: 273


View Profile
« Reply #2 on: August 21, 2009, 01:37:48 PM »

I'm not familiar with kermit in this application.  It has been alleged that minicom had some problems in this area, though.  Most people seem to be having the most luck with putty.  (On your host machine:  "apt-get install putty".)

If you've updated the Uboot using alpha-6, you've got 2-directional communications on the physical link so the problem must lie elsewhere.  Make sure your virtual serial port is set to 115200 8/N/1.  See  http://www.openplug.org/plugwiki/index.php/Getting_the_Plug_Computer_Running_with_an_Operating_System .

Good luck.
Logged

1abc2
Newbie
*

Karma: 0
Posts: 11


View Profile
« Reply #3 on: August 21, 2009, 04:58:57 PM »

Hi.
Thanks for the reply. I meant with Sheevaplug Installer the alpha6 installer. I installed Putty on my Archlinux laptop and it's working perfectly. Thanks a lot Cheesy.
Logged

dattaway
Jr. Member
**

Karma: 5
Posts: 91



View Profile WWW
« Reply #4 on: August 24, 2009, 06:54:28 AM »

Hit any key to stop autoboot: 0

does it to me too!  Can't stop u-boot.  Tried minicom and cu.

Reflashing with alpha-6 works, but this problem keeps coming up and requires a new reflash every time...
Logged

1abc2
Newbie
*

Karma: 0
Posts: 11


View Profile
« Reply #5 on: August 26, 2009, 12:18:43 AM »

Try putty
Logged

Pages: [1]
Print
Jump to: