• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Starting Again from Scratch with my Sheevaplug  (Read 1300 times)
madmike
Newbie
*

Karma: 0
Posts: 13


View Profile
« on: August 25, 2013, 12:22:09 PM »

Hi,
After a couple of years or 4 of faithful service, my Sheevaplug stopped booting on its own. If there was some kind of power loss, then it would boot to
Marvell>>
and I would have to type boot, via the serial console, to get it to reboot fully.

Eventually I decided to try to resolve this and to update the Sheevaplug linux at the same time. So, I used dd on my macbook to write Wheezy to my 4GB SD Card but now I cann't get past Marvell>>  at all. I followed some instructions to set the environment variables to boot into the SD Card, but now I get the error

** Unable to read "/boot/uImage" from mmc 0:1 **
## Booting Image at 00800000 ...
Bad Magic NUmber
Marvell>>

and that's as far as I can get. If I try to follow the instructions on plugcomputer.org wiki, I quickly get to a page that is no longer available and so I am stuck. Can someone please point me at some start to finish instructions as to how to configure u-boot upwards, or alternatively help me to understand what I need to set the variables to to allow me to auto boot from SD Card once again?

Many thanksm

Madmike.
Logged

odoll
Full Member
***

Karma: 0
Posts: 148


View Profile
« Reply #1 on: August 27, 2013, 03:03:39 AM »

If you want to install/run Wheezy from scratch I recommend to have a look at Martin Michlmayr's instructions starting with an u-boot update/upgrade http://www.cyrius.com/debian/kirkwood/sheevaplug/uboot-upgrade/. After this continue with the Wheezy installation described at http://www.cyrius.com/debian/kirkwood/sheevaplug/install/.

BTW: Does sb have an actual DENX u-boot version which works for the standard SheevaPlug? I tried to compile my own version, but the standard DENX has no SD card support!? And I got stuck in trying to apply some Marvel patches to the DENX version.
« Last Edit: August 27, 2013, 03:09:02 AM by odoll » Logged

Yapapa
Newbie
*

Karma: 0
Posts: 6


View Profile
« Reply #2 on: August 27, 2013, 04:00:20 AM »

I suffered with Martin's wheezy instructions - I did not succeed to convince denx to do a multiboot.
Maybe all these denx version are too sophisticated for the good old sheevaplug.
I went back to the u-boot gento patch version and squeeze - the ESIA helped me quite well to flash the u-boot.
so far I learned my lesson: never touch a running system! So for me no wheezy and no denx no more!
all the best to you when you'll go down that road...
Y.
Logged

Pages: [1]
Print
Jump to: