• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: building libpam for marvell cross compiler  (Read 1751 times)
bad_gui
Jr. Member
**

Karma: 0
Posts: 50


View Profile
« on: June 11, 2013, 07:38:44 PM »

I am trying to cross compile openvpn 2.3.0 using arm-marvell-linux-gnueabi.tar.bz2 version 1.00 from 04/27/2011
Quote
gcc version 4.4.5 20100614 (prerelease) (FSF GNU GCC branch-4.4.5. Marvell GCC 2010q4-113)

The compile fails with an error about libpam not found

On my guruplug server plus, I have libpam.so.0.83.0 so I am looking for the source of this version and follow the
instructions here on cross compiling linux-pam to add it to the cross compile environment 
http://www.ailis.de/~k/archives/19-arm-cross-compiling-howto.html

Problem is that I can't find the source for version 0.83.
Kernel .org only goes to 0.80 https://www.kernel.org/pub/linux/libs/pam/pre/library/
linux-pam.org jumps from 0.81 to 0.99 http://www.linux-pam.org/pre/library/

Any ideas on whether building against a different lib will break openvpn on the plug?
Or can I install libpam 0.99 on the plug alongside the 0.83 version?
Logged

Pages: [1]
Print
Jump to: