• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: [GURUPLUG] Can't get Bluetooth working  (Read 1033 times)
doragasu
Newbie
*

Karma: 0
Posts: 34


View Profile
« on: January 26, 2013, 03:30:58 AM »

I have a modded Guruplug that has been working perfect for years. But until now I never used Bluetooth, and I want to use it now. Unfortunately, I can't get it to work. I'm running kernel 3.4.7, and it looks like there are some problems when loading Bluetooth drivers. These are some debug messages popped during bootup:

Code:
libertas_sdio: failed to load firmware
libertas_sdio: probe of mmc0:0001:1 failed with error -5
Bluetooth: vendor=0x2df, device=0x9105, class=255, fn=2
Bluetooth: request_firmware(helper) failed, error code = -2
Bluetooth: Failed to download helper!
Bluetooth: Downloading firmware failed!
uap_probe: vendor=0x02DF device=0x9104 class=0 function=1
request_firmware() failed (helper), error code = 0xfffffffe
Firmware Init Failed
uap_probe: uap_add_callback failed
uap_sdio: probe of mmc0:0001:1 failed with error -1

Maybe I'm missing some firmware files... could this be the problem? how can I solve it?

PS: I have also never used WiFi, and I don't need it right now, but I'm suspecting it is also not working...
Logged

doragasu
Newbie
*

Karma: 0
Posts: 34


View Profile
« Reply #1 on: January 26, 2013, 08:32:00 AM »

I found the solution in this post

I was missing firmware files sd8688.bin and sd8688_helper.bin. They came in my original Guruplug installation under /root/firmware. I copied these two files to /lib/firmware and also created the symilink sd_helper.bin pointing to sd8688_helper.bin. Now I can use BT without problems.
Logged

Pages: [1]
Print
Jump to: