Dreamplug AP using mwifiex (SD8787)

(1/2) > >>

debio:
I have a recent Dreamplug, and it looks like at some point the wireless chipset switched to SD8787. uap8xxx does not bring up this card, and it looks like the official kernel driver is mwifiex. Looking at various kernel mailing lists, it looks like this driver *does* support both UAP and STA mode, but I haven't figured out how to get it into UAP mode.

Has anyone tried this? I can't find any mailing list discussions about using this driver in UAP mode, just patches from Marvell that supposedly add it.

debio:
Self-reply since I apparently can't edit the original post:

It looks like uAP support only entered the mainline kernel in 3.6, and a lot of fixes are making it into 3.7.

I'm currently building a 3.7rc1 kernel. I'll see how it goes.

debio:
Got a 3.7rc1 kernel running.

The mwifiex_sdio kernel module seems to allow the WiFi adapter to simultaneously act as client and AP (and p2p, whatever that is). When the WiFi PHY comes up, it creates three interfaces: mlan0, uap0, and p2p0.
I'm not sure how to configure uap0 to make things work. It seems I can't just set the SSID through iwconfig. I ran hostapd, and while it failed to create the monitor interface it normally uses, I did start seeing SSID broadcasts from my AP, and I could associate with it. I couldn't get full network connectivity, but that may have just been due to my IPTables rules being too strict or somesuch. I didn't get the chance to find out because apparently if you kill hostapd, the system locks. No kernel panic messages on the serial port; it just dies.

Also, things seem to be alright if I modprobe mwifiex_sdio myself, but the one time I removed it from the blacklist and it was loaded on boot, the system hung. Haven't checked whether it's repeatable, but it's more than a little frightening.

Anyway, this is looking pretty interesting. If anyone is interested in fiddling with this, I could post up the config I'm using (although it's really just an updated version of one from http://www.xilka.com/). I could probably get the uImage and modules up somewhere as well, but this probably isn't something stable enough for general usage. Actually, it's probably a terrible idea to use this if you don't have a JTAG box.

debio:
Most of the instability seems to be when bringing the card up. Since that first time when closing hostapd hung the box, I haven't had another hang.
When the card comes up properly, I can start hostapd and have a working AP with no encryption. The client fails to associate if I enable WPA - not sure if it's implemented yet. I don't even know if this card has hardware crypto or not, so I don't know whether it needs to be implemented.

Thinking about emailing one of the Marvell guys that's submitting code for inclusion in the kernel, but I'm not sure if this is worth bothering them about.

nago:
Hello,
I' m using the 3.7.4 kernel on my guruplug server (same wifi component)  and the guruplug hangs sometimes (client use) during the initialisation of the mwifiex module or during the DHCP processing. Marvell developped a "new" firmware bin file for the SD8787 and i find that it hangs less  than before with it.
 
Link for the sd8787_uapsta.bin:
http://git.chromium.org/gitweb/?p=chromiumos/third_party/marvell.git;a=commit;h=9fa10832efefc59af8d1c2d7fd1a07f218f3a606

But that didn't solve the hanging problem. I will wait for new mwifiex patchs.

Navigation

[0] Message Index

[#] Next page