• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: No uboot Bricked sheevaplug  (Read 3467 times)
splatter
Newbie
*

Karma: 0
Posts: 4


View Profile
« on: October 09, 2012, 07:20:12 AM »

Hello Group,

Can anyone tell me if it is possible to get a sheevaplug back after bricking the Uboot, and  point me to or walk me through it?

I was trying to update from Marvel to Denx  using this page:
http://www.cyrius.com/debian/kirkwood/sheevaplug/uboot-upgrade.html

Downloaded the correct version slapped it on usb and re-flashed no issue. But on initial reset it just gives me a big green prompt. I have the sheevaplug installer but don't understand if I'm not getting a mini-usb com port connection how I'm supposed to do anything with that.

So can this be fixed or do I need another plug?

TIA



 
Logged

splatter
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #1 on: October 09, 2012, 08:04:15 AM »


Sorry to reply to myself I couldn't seem to find an edit button.  So I checked a few threads down and the link was broken but pointed me to:
http://www.plugcomputer.org/Documentation/howtos/setting-up-openocd-under-linux/#Building_OpenOCD

I also read that the mini-usb can also be used as a jtag port or should I fireup a live-distro to do this? I'm using winxp & putty over com5 so the gap I'm not sure of is how to get some response (jtag?) from the box.

Similarly to this post I have one green light and no blue.
http://www.plugcomputer.org/plugforum/index.php?topic=6044.0
orig here
http://forums.plugpbx.org/index.php/topic,298.0.html

I found openOCD for windows, when I get home I'll try that but again I'm not sure how that works when the com port isn't responding.
Logged

splatter
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #2 on: October 09, 2012, 05:48:56 PM »

Ok so I follow this:

http://www.newit.co.uk/forum/index.php/topic,2835.msg8168.html#msg8168

Using a debian livecd I downloaded the elf file started openocd  & used telnet to hit the server with

reset;sheevaplug_init;load_image u-boot.elf;resume 0x00600000

And got my blue light back!! Problem is it doesn't persist past the reboot. Argh.... So what am I missing here?

Tia
Logged

guidol
Full Member
***

Karma: 10
Posts: 128



View Profile
« Reply #3 on: October 11, 2012, 03:55:37 AM »

I think you did only load the u-boot into ram and did start it...but to be persistent you need to flash it to the sheeva.

Take a look at http://www.cyrius.com/debian/kirkwood/sheevaplug/uboot-upgrade.html

on the other thread you could read "you are ready to start restoring your plug." after booting the u-boot.

I thin "restoring" does mean to flash the sheeva.
Logged

splatter
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #4 on: October 11, 2012, 08:40:48 AM »

Well shoot, thanks for the input.

Unfortunately that page was what got me into this mess as the denx image file link he provides for some reason Does Not load in my sheevaplug. Now I have an image.elf file which does work can I use it or do I need to scour around to find this version in that format?

In other words from his page can I do

fatload usb 0:1 0x0800000 u-boot.elf?

instead of usb fatload usb 0:1 0x0800000 u-boot.kwb?


I realize I can download the non-compiled version from the download section but I'm not a native Linux user so compiling is a pain, and something I'm not knowledge.
Logged

bigbear59
Newbie
*

Karma: 0
Posts: 26


View Profile
« Reply #5 on: October 11, 2012, 09:39:45 PM »

Have you tried
     http://www.plugcomputer.org/plugforum/index.php?topic=3680.msg19577#msg19577 ?

Luck,
BigBear59
Logged

Give me a fish, I eat for a day.  Teach me to fish, I eat for a lifetime.
"Do you have any spades?"

Pages: [1]
Print
Jump to: