• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: GuruPlug stops during boot  (Read 2509 times)

Karma: 0
Posts: 1

View Profile
« on: September 18, 2012, 12:43:54 PM »

I decided to clean up the software on my GuruPlug, since there's a lot of packages installed by default that I don't need. So I found a script online that worked by trying to mark each package as automatic, and then removing all packages that weren't necessary. I ran the script several times, until the only package that I was asked about was Aptitude.

Unfortunately that process removed more than expected, so now I can't telnet to it, nor does it get an IP address assigned, as it's not displayed in my router's menu any longer. So I went ahead and bought the Jplug and am now connected to it through Putty.

The plug boots just fine, however it stops clean at the following message:

stat: cannot stat '/usr/bin/screen': No such file or directory.

Screen is a package I installed myself to allow me to run several different programs and view the output of any of them at any point. So as it shouldn't be necessary for the system, I don't know why it stops there.

I would like to try and fix the problems by installing the necessary packages with Aptitude, provided I can get the plug through a complete boot, so I'd like some help on what to do to fix the screen problem.

Pages: [1]
Jump to: