• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: D@ SD slot - Disk Utility does not see anything in slot  (Read 2105 times)
pwhalley
Newbie
*

Karma: 0
Posts: 12


View Profile
« on: May 21, 2012, 09:30:40 PM »

Greetings all:

I am new to the D2 and want to use it as a home automation controller with MisterHouse.  I have other applications I want to explore as well so I would like to be able to change quickly and SIMPLY between application configs by swapping SD cards with different software loads and leave the 'stock' configuration (OS)largely unmolested 'till I am very confident that I know what I am doing and have confidence that if I break the software, I am also able to unbreak it quickly and easily. I will explore net boot options later.

The D2 came with 10.4 and I am staying there for the time being.  I have updated Ubuntu and done nothing else to the base config.

Disk Utility will not recognize the presence of a 16G and 8G micro SD card in 2 different adapters in the
SD slot.  The OS mounts the device in /media/ as expected and I can write and read to it there.  I have also tried 2G SD card 2G micro SD and a 16G SDHC I SanDisk Extreme Pro in the slot, and none show up in Disk Utility! The 2G SD and 2G micro SD won't show up at all in the SD slot but the 2G micro SD will show up in /media/ and in Disk Utility when in a USB adapter in any USB port (actually, any micro SD in the adapter is found in any USB port).

Has anyone else seen this kind of behavior?  I am at a loss to explain how the internal card reader is causing this problem unless it is a driver issue or a very particular defect in the reader...

Considering these idiosyncrasies, I am hesitant to spend time getting the 16G card prepared to boot  'till I am confident that my hardware (D2) is fully functional and that preparing the micro SD card in a USB adapter will work when moved to the SD slot.  If there was an image I could download to the card that I knew would boot from D2 SD slot that would be helpful.

Any suggestions?

Peter
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #1 on: May 22, 2012, 08:05:46 PM »

Sorry , I can't full undrstand your question

I just to explain what I test

1. I test plug-in 2 size sd card into D2 , one is 8GB another one is 16GB
2. both could be detect , no matter I check it at ubuntu or I check it at console (type mount and dmesg) ,both I could found a storage be mounted , and I used it (like copy file into sdcard) also work
3. I check Disk utitlity , I also found it is same as I plug-in sd card to D2 , but I think it not imapct not impact your used case right?
4. I wounder for Disk utility, it is beacuse there are one card reader at D2 plug cause, I also try it at my desktop , used one card reader + 16GB sd-card ,plug-in my computer, I check Disk utility , it just show up onw card reader , not see any 16GB sd card info , so if you just wonder the Disk-utility behavior , I think D2 was same as Desktop
Logged

pwhalley
Newbie
*

Karma: 0
Posts: 12


View Profile
« Reply #2 on: May 22, 2012, 10:07:43 PM »

Mentor:

I think you understood well enough.  It looks like DiskUtility is not working right.  This was causing confusion since I wasn't seeing devices there that should have been visible.

I am now booting from SD card as desired.

Thanks

Peter



Logged

Pages: [1]
Print
Jump to: