• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: help with uboot  (Read 1462 times)
majedalanni
Newbie
*

Karma: 0
Posts: 7


View Profile
« on: April 25, 2012, 07:27:06 PM »

hi this is my first fw_printenv

bootcmd=setenv ethact egiga0; ${x_bootcmd_ethernet}; setenv ethact egiga1; ${x_bootcmd_ethernet}; ${x_bootcmd_usb}; ${x_bootcmd_kernel}; setenv bootargs ${x_bootargs} ${x_bootargs_root}; bootm 0x6400000;
bootdelay=3
baudrate=115200
x_bootcmd_ethernet=ping 192.168.2.1
x_bootcmd_usb=usb start
x_bootcmd_kernel=fatload usb 0 0x6400000 uImage
x_bootargs=console=ttyS0,115200
x_bootargs_root=root=/dev/sda2 rootdelay=10
stdin=serial
stdout=serial
stderr=serial
ethact=egiga0
ethaddr=F0:AD:4E:00:7E:75
eth1addr=F0:AD:4E:00:7E:76

now my its
ethaddr=F0:AD:4E:00:7E:75
eth1addr=F0:AD:4E:00:7E:76
baudrate=115200
bootdelay=3
x_bootcmd_ethernet=ping 192.168.2.1
x_bootcmd_usb=usb start
x_bootcmd_kernel=fatload usb 0 0x6400000 uImage
x_bootargs=console=ttyS0,115200
x_bootargs_root=root=/dev/sda2 rootdelay=10
stdin=serial
stdout=serial
stderr=serial
ethact=egiga0

i'm missing bootcmd command and I don't have jtag but i have fw_setenv. please can one help me to restore my orginal env before I reboot and brick it pleaaaaaaaaase Cry
Logged

majedalanni
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #1 on: April 25, 2012, 08:16:05 PM »

I play with it

and its
ethaddr=F0:AD:4E:00:7E:75
eth1addr=F0:AD:4E:00:7E:76
baudrate=115200
bootdelay=3
x_bootcmd_ethernet=ping 192.168.2.1
x_bootcmd_usb=usb start
x_bootcmd_kernel=fatload usb 0 0x6400000 uImage
x_bootargs=console=ttyS0,115200
x_bootargs_root=root=/dev/sda2 rootdelay=10
stdin=serial
stdout=serial
stderr=serial
ethact=egiga1
bootcmd=usb start; fatload usb 0 0x6400000 uImage; setenv bootargs console=ttyS0,115200 root=/dev/sda2 rootdelay=10; bootm 0x6400000;


is that right ?
Logged

Pages: [1]
Print
Jump to: