• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: U-Boot with load2ext for Guru server PLUS: Who has a working version?  (Read 1838 times)
nomiz
Newbie
*

Karma: 0
Posts: 3


View Profile
« on: March 17, 2012, 03:41:29 AM »

Hi all,

Is there someone with a working U-Boot version voor the Guru server PLUS with support for load2ext?

I've tried to compile U-Boot myself, and I've tried flipflip's version, but both bricked my device. Only the stock ROM seems to be working.

What experience do you guys have with an up-to-date U-Boot version on a Guru server PLUS?

If you have a working version, could you please post the bin/kwb?

Thanks a lot!
Logged

pacolm
Full Member
***

Karma: 1
Posts: 102


View Profile
« Reply #1 on: March 17, 2012, 06:57:46 AM »

Here is the uboot version I have in both guruplugs, that supports ext2load

* u-boot.3.4.27.bin (463.53 KB - downloaded 103 times.)
Logged

nomiz
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #2 on: March 17, 2012, 07:46:10 AM »

Thanks!

But is does not work on my device... It just stays bricked after writing the U-Boot bin... Why??  Cry

Had to put the original uboot.guruplug.bin back..   Angry
Logged

ppmt
Full Member
***

Karma: 1
Posts: 129


View Profile
« Reply #3 on: March 17, 2012, 11:50:16 AM »

It is not going to help you but I installed the uboot from flipflip and it worked.

Can't remember what I did as it was some time ago but I don't it is any different than loading the stock uboot.
Logged

pacolm
Full Member
***

Karma: 1
Posts: 102


View Profile
« Reply #4 on: March 17, 2012, 03:01:34 PM »

Hi,

 I'm pretty sure that this uboot works for guruplug server plus, are the commands you're using the following?. A change in the addresses could make you plug get bricked

Code:
#change uboot
tftp 0x6400000 u-boot.3.4.27.bin
nand erase 0x0 0x100000
nand write.e 0x6400000 0x0 0x100000
reset

Could you post the commands you are using?

Regards,

PacoLM
Logged

nomiz
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #5 on: March 18, 2012, 04:12:35 AM »

WORKS!  Grin Thank you!

I have tried the U-Boot version posted above using OpenOCD, and that bricked the device! Weird?!

Using tftp was the key!

But still: Why does OpenOCD work with the stock ROM?
Logged

Pages: [1]
Print
Jump to: