• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Weird behavior with SDHC card Transcend 32GB Class 10  (Read 4155 times)
vinz2k
Newbie
*

Karma: 0
Posts: 5


View Profile
« on: March 02, 2012, 03:07:45 PM »

Hi everyone,

I'm trying to create several partitions on a Transcend 32GB SD Card whith my shevaplug and I get weird behavior :
- When I create a 500MB partition and a second 500MB partition, I can format it and mount it
- But when I create a 1GB partition and a second 500MB partition, during the formating of the second one, I get these error messages :

Code:
mmcblk0: error -110 transferring data, sector 3121088, nr 128, card status 0xd00
mmc0: Timeout waiting for hardware interrupt.
mmc0: hw_state=0x22f8, intr_status=0x0811 intr_en=0x4002
end_request: I/O error, dev mmcblk0, sector 3121088
Buffer I/O error on device mmcblk0p2, logical block 127984
lost page write due to I/O error on mmcblk0p2
end_request: I/O error, dev mmcblk0, sector 3121096
Buffer I/O error on device mmcblk0p2, logical block 127985
lost page write due to I/O error on mmcblk0p2
end_request: I/O error, dev mmcblk0, sector 3121104
Buffer I/O error on device mmcblk0p2, logical block 127986
lost page write due to I/O error on mmcblk0p2
end_request: I/O error, dev mmcblk0, sector 3121112
Buffer I/O error on device mmcblk0p2, logical block 127987
lost page write due to I/O error on mmcblk0p2
end_request: I/O error, dev mmcblk0, sector 3121120
Buffer I/O error on device mmcblk0p2, logical block 127988
lost page write due to I/O error on mmcblk0p2
end_request: I/O error, dev mmcblk0, sector 3121128
Buffer I/O error on device mmcblk0p2, logical block 127989

fdisk -l /dev/mmcblk0

Disk /dev/mmcblk0: 33.6 GB, 33554432000 bytes
4 heads, 16 sectors/track, 1024000 cylinders
Units = cylinders of 64 * 512 = 32768 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x41216c46

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1               1       32769     1048600   83  Linux
/dev/mmcblk0p2           32770       48770      512032   83  Linux

- And when I create a 2GB partition and a second 500MB partition, I can format it, but when I mount it I get these error messages :
Code:
mount -t ext3 /dev/mmcblk0p2 /media/
EXT3-fs (mmcblk0p2): error: can't find ext3 filesystem on dev mmcblk0p2.
mount: wrong fs type, bad option, bad superblock on /dev/mmcblk0p2,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

fdisk -l /dev/mmcblk0

Disk /dev/mmcblk0: 33.6 GB, 33554432000 bytes
4 heads, 16 sectors/track, 1024000 cylinders
Units = cylinders of 64 * 512 = 32768 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x41216c46

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1               1       65537     2097176   83  Linux
/dev/mmcblk0p2           65538       81538      512032   83  Linux

I'm using 3.0.4 kernel from http://sheeva.with-linux.com/sheeva
Code:
uname -a
Linux neutron 3.0.4 #2 PREEMPT Sun Sep 18 15:58:49 MDT 2011 armv5tel GNU/Linux

Have you any ideas where could come from this problem ?

Thanks !
Logged

spinifex
Full Member
***

Karma: 8
Posts: 167



View Profile WWW
« Reply #1 on: March 02, 2012, 03:34:24 PM »

what did you use to create your partitions?
I have had similar problems when I do not use fdisk.
Logged

vinz2k
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #2 on: March 02, 2012, 10:25:59 PM »

I'd use fdisk to create partitions and mkfs.ext3 to format it.
Logged

vinz2k
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #3 on: March 10, 2012, 10:14:44 PM »

Any ideas on what can cause this problem ?
Logged

odoll
Full Member
***

Karma: 0
Posts: 148


View Profile
« Reply #4 on: March 12, 2012, 03:20:08 AM »

No direct contribution, but which Plug are you using and which uboot is an that device? (Not saying that updating uboot will fix this!?)
Logged

vinz2k
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #5 on: March 14, 2012, 02:55:58 AM »

I'm using SheevaPlug (no eSATA) and here is my U-Boot version :
Code:
Marvell>> version

U-Boot 2011.03 (Apr 26 2011 - 21:50:07)
Marvell-Sheevaplug - eSATA - SD/MMC
gcc (Debian 4.5.2-8) 4.5.2
GNU ld (GNU Binutils for Debian) 2.21.0.20110327
Logged

tinker
Newbie
*

Karma: 2
Posts: 43


View Profile
« Reply #6 on: April 20, 2012, 08:45:53 AM »

What is the output of fdisk -l   ?
Logged

vinz2k
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #7 on: April 20, 2012, 09:11:33 AM »

Too late... I've sold the 32GB. I have to buy a 16GB to try it on the sheevaplug.
Logged

Pages: [1]
Print
Jump to: