• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Mono develop on D2Plug?  (Read 2129 times)

Karma: 0
Posts: 12

View Profile
« on: February 07, 2012, 04:11:24 PM »

Hi all!

I'm trying to install Mono develop on my D2Plug. Mono is a cross platform .NET development framework and since I need a version > 2.4 (which is the version found in the Synaptics package manager), the only way to do this is to go to get it from the badgerports repository. (This is what _I_ believe?)

Ubuntu Lucid (10.04 LTS)

Users of Ubuntu 10.04 LTS (Lucid Lynx) can install 2.10.5 by using Synaptic from the badgerports repository. badgerports is an unofficial community project from one of the Debian/Ubuntu Mono developers to ship latest Ubuntu packages for Ubuntu LTS users. Please visit the URL below for full information on enabling these packages:

, http://mono-project.com/DistroPackages/Ubuntu

Well, to save you the details, this does not work that easy. I tried to follow the install instructions found there but run into issues (due to the ARM processor I think).

I mailed the contact person on the site (http://badgerports.org) with my problems, and I guess he would give me further answers if i just asked him, but since I think the solution might interest more people than just me, why not ask this question on this public forum?

When I followed the standard instructions I had problems. I mailed the site contact person and this was his answer:
I'm afraid I don't publish packages for ARM - I rely on Launchpad's PPA
infrastructure to build my packages, and mere mortals like me aren't
given access to ARM builders.

My question to the site contact person was if it was impossible to install Monodevelop version > 2.4 on the D2Plug?

It's actually possible, but not so user-friendly.

You're going to need to compile a couple of things yourself, but you can
use the badgerports source packages to do it cleanly-ish.

Install devscripts and wget, make a new folder, and run "dget
https://launchpad.net/~directhex/+archive/ppa/+files/mono_2.10.5-1~dhx1~lucid1.dsc" - this should download the mono source package from badgerports, and extract it to the current folder. Switch into the mono-2.10.5 folder and run dpkg-buildpackage. It'll throw an error about missing build dependencies - install them, and try again. Eventually it'll start compiling Mono (which will take a few hours)

Once it's done, there'll be a bunch of .deb files in the parent folder -
you can install them with "dpkg -i".

Once you have Mono 2.10.5 for ARM installed, you can actually just
download the amd64 MonoDevelop package directly from
https://launchpad.net/~directhex/+archive/ppa/+packages?field.name_filter=&field.status_filter=published&field.series_filter=lucid - you don't need to recompile it, because .NET code is cross-platform, so the package is cross-platform too.

Any other missing dependencies, check my PPA URL above - if the package
is _all.deb, download it and install with "dpkg -i". If there are
_i386.deb or _amd64.deb packages, you'll need to recompile it yourself
by running "dget" on the .dsc file and following the procedure I
outlined above for Mono

Sorry this isn't any easier than it could be, but I did some less-common
architecture builds for badgerports 6.06 - it took about 90% of my
packaging time, and had less than a dozen users.

Well, I installed the devscripts (via "default" Synaptics package manager on D2Plug, I downloaded the mono source package from badgerports:
dget https://launchpad.net/~directhex/+archive/ppa/+files/mono_2.10.5-1~dhx1~lucid1.dsc

I exctracted the package
sudo tar xvjf mono_2.10.5.orig.tar.bz2

I switched to the directory:
ubuntu@D2Plug:~$ cd mono-2.10.5

and tried to build:
ubuntu@D2Plug:~/mono-2.10.5$ sudo dpkg-buildpackage
[sudo] password for ubuntu:
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
tail: cannot open `debian/changelog' for reading: No such file or directory
dpkg-buildpackage: error: tail of debian/changelog gave error exit status 1

How should I proceed? What should my next step be? How should I force "dpkg-buildpackage: error: tail of debian/changelog gave error exit status 1"?


Karma: 0
Posts: 12

View Profile
« Reply #1 on: February 12, 2012, 03:55:09 AM »

Never mind, I have got an answer to my question on http://ubuntuforums.org/showthread.php?p=11680616.

Pages: [1]
Jump to: