• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: sheeva/dream 3.2.5 new kernel available  (Read 3762 times)
cbxbiker61
Global Moderator
Sr. Member
*****

Karma: 38
Posts: 497


View Profile
« on: February 07, 2012, 12:47:33 PM »

3.2.5 is now available.

This version should have no problems booting on any of the Sheeva or Dream computers.

For everything besides Dreamplugs:
sudo ./README-PLUG-UPDATE.sh 3.2.5 --nandkernel (installs to nand)
or:
sudo ./README-PLUG-UPDATE.sh 3.2.5 --rootkernel (installs to /boot)

For Dreamplugs:
sudo ./README-DREAM-UPDATE.sh 3.2.5 (installs to /boot)

Kernel and modules are available from the following locations:

http://www.plugapps.com/mirror/with-linux/
http://www.xilka.com/sheeva/

Features systemd, e-sata, dmcrypt, IPV6, CIFS, NFS4, EXT3, EXT4, JFS, XFS, FUSE(for ntfs-3g), UBIFS, usb-serial, uvcvideo, iptables, appletalk, bluetooth, v4l and ppp.

The kernel source is available on the plugapps mirror (it syncs once a day, so it may be up to 24 hours late).
Logged

mgillespie
Full Member
***

Karma: 7
Posts: 239



View Profile
« Reply #1 on: February 08, 2012, 11:28:13 AM »

Confirmed working on my Sheevaplug running Denx U-Boot 2011.12 (Jan 08 2012 - 21:53:47)

This is the first 3.2 kernel that has worked for me using this U-Boot (they all worked using the Marvell U-Boot).
Logged

spinifex
Full Member
***

Karma: 8
Posts: 167



View Profile WWW
« Reply #2 on: February 08, 2012, 03:52:17 PM »

When you say first , or first that you tried?
Did you try the modified 3.2.4?
Logged

mgillespie
Full Member
***

Karma: 7
Posts: 239



View Profile
« Reply #3 on: February 10, 2012, 10:01:58 AM »

First I tried...

Unfortunately, anyone else that takes the link from the Debian Linux page will also see the recommendation to upgrade u-boot.

http://www.cyrius.com/debian/kirkwood/sheevaplug/install.html

"You have to upgrade the u-boot boot loader before you can install Debian. "

This was the root of all my problems :-(
Logged

spinifex
Full Member
***

Karma: 8
Posts: 167



View Profile WWW
« Reply #4 on: February 10, 2012, 05:58:35 PM »

I think this is an ill considered approach by Debian.
Upgrading u-boot on a Dreamplug is not even documented by globalscale. 
Logged

Guber1
Newbie
*

Karma: 0
Posts: 24


View Profile
« Reply #5 on: February 14, 2012, 08:03:21 AM »

Hi, i'm trying to install this kernel but i can't i have downloaded the README file but when i introduce the command to start the update sudo ./README-PLUG-UPDATE.sh 3.2.5 --nandkernel
nothing happens just the prompt again and also no errors just nothing.
what am i doing wrong?
Logged

cbxbiker61
Global Moderator
Sr. Member
*****

Karma: 38
Posts: 497


View Profile
« Reply #6 on: February 14, 2012, 12:31:48 PM »

Hi, i'm trying to install this kernel but i can't i have downloaded the README file but when i introduce the command to start the update sudo ./README-PLUG-UPDATE.sh 3.2.5 --nandkernel
nothing happens just the prompt again and also no errors just nothing.
what am i doing wrong?

Try enabling bash debug mode, it prints status of the command as it runs.

 sudo bash -x ./README-PLUG-UPDATE.sh 3.2.5 --nandkernel
Logged

Guber1
Newbie
*

Karma: 0
Posts: 24


View Profile
« Reply #7 on: February 14, 2012, 03:36:24 PM »

root@debian:~# bash -x ./README-PLUG-UPDATE.sh 3.2.6 --nandkernel
+ set -e
+ set -u
+ ProgName=./README-PLUG-UPDATE.sh
+ KVer=
+ ERROR=0
++ which flash_eraseall
+ FLASH_ERASEALL=

this i get
Logged

cbxbiker61
Global Moderator
Sr. Member
*****

Karma: 38
Posts: 497


View Profile
« Reply #8 on: February 14, 2012, 04:14:24 PM »

root@debian:~# bash -x ./README-PLUG-UPDATE.sh 3.2.6 --nandkernel
+ set -e
+ set -u
+ ProgName=./README-PLUG-UPDATE.sh
+ KVer=
+ ERROR=0
++ which flash_eraseall
+ FLASH_ERASEALL=

this i get

OK, good.  What happened was "which" returned non-zero when it couldn't find flash_eraseall, which caused the script to apport because of the "set -e".  I updated the script to move the "set -e" below the "which flash_eraseall".  The new version should work as intended.
Logged

Guber1
Newbie
*

Karma: 0
Posts: 24


View Profile
« Reply #9 on: February 14, 2012, 04:23:12 PM »

ok thanks now it works but now i have a md5 error:
+ Md5Compare sheeva-3.2.6-Modules.tar.gz sheeva-3.2.6-Modules.tar.gz.md5
++ cut '-d ' -f1
++ cat sheeva-3.2.6-Modules.tar.gz.md5
++ cut '-d ' -f1
++ md5sum sheeva-3.2.6-Modules.tar.gz
+ [[ b6d1c3d28fafc41d0c11dc04b8ad67ca != de0c18f3aa00791dacf5c7592a6ddf6d ]]
+ echo 'Bad md5 detected on sheeva-3.2.6-Modules.tar.gz'
Bad md5 detected on sheeva-3.2.6-Modules.tar.gz
+ exit 1

maybe it's wrong on the server the md5 code, now i'm trying to install the new version 3.2.6

edit: it works perfect with 3.2.5
« Last Edit: February 14, 2012, 04:25:28 PM by Guber1 » Logged

cbxbiker61
Global Moderator
Sr. Member
*****

Karma: 38
Posts: 497


View Profile
« Reply #10 on: February 14, 2012, 06:46:54 PM »

ok thanks now it works but now i have a md5 error:
+ Md5Compare sheeva-3.2.6-Modules.tar.gz sheeva-3.2.6-Modules.tar.gz.md5
++ cut '-d ' -f1
++ cat sheeva-3.2.6-Modules.tar.gz.md5
++ cut '-d ' -f1
++ md5sum sheeva-3.2.6-Modules.tar.gz
+ [[ b6d1c3d28fafc41d0c11dc04b8ad67ca != de0c18f3aa00791dacf5c7592a6ddf6d ]]
+ echo 'Bad md5 detected on sheeva-3.2.6-Modules.tar.gz'
Bad md5 detected on sheeva-3.2.6-Modules.tar.gz
+ exit 1

maybe it's wrong on the server the md5 code, now i'm trying to install the new version 3.2.6

edit: it works perfect with 3.2.5

If you get a bad checksum...just delete the bad file and rerun the script.  The md5sum's match on the server.
Logged

Guber1
Newbie
*

Karma: 0
Posts: 24


View Profile
« Reply #11 on: February 15, 2012, 01:12:20 AM »

i try again and it works, now i have 3.2.6 kernel, THANK YOU.
Logged

Pages: [1]
Print
Jump to: