• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: D2Plug Support Needs Work  (Read 1626 times)
joshiepoo
Newbie
*

Karma: 0
Posts: 1


View Profile
« on: January 28, 2012, 04:23:50 PM »

I have to say, I was impressed withthe D2Plug's specs when it first came out.  However, after having it for two weeks and trying to cross compile drivers using the toolchain that is provided on the D2plug site, I am disappointed.  The toolchain that I downloaded: http://www.plugcomputer.org/405/us/d2plug/tool-chain/arm-marvell-linux-gnueabi-vfp.tar.bz2 does not work.  I get this error: arm-marvell-linux-gnueabi-gcc --version
-bash: /home/ubuntu/toolchains/arm-marvell-linux-gnueabi-vfp/bin/arm-marvell-linux-gnueabi-gcc: cannot execute binary file.  And yes I'm running them with the correct permissions.  This error tells me that the cross-compile binaries were complied wrong (as in with the -c flag).  This is piss poor.  I have followed the directions in the software user guide, just trying to build the kernel and I get similar errors.  I've dropped days on this device, have tried to get support from globalscale technologies and it looks like it's going back.  By the way, I have the sheeva plug and it works great, just a little under powered for me.
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #1 on: January 31, 2012, 07:47:51 PM »

I have give a try a tmy d2plug package , it work fine

I list my precedure for you ,maybe have some help


1.download tool-chain,kernel ..package form "http://www.plugcomputer.org/downloads/d2plug/index.html"

2.untar toolchain

3.build kernel, into kernel folder , type command  "make ARCH=arm dove_d2plug_defconfig" than "make ARCH=arm CROSS_COMPILE=<your intsall toolcahin path>/arm-marvell-linux-gnueabi-vfp/bin/arm-marvell-linux-gnueabi- uImage

Logged

Pages: [1]
Print
Jump to: