• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: d2plug wireless issues  (Read 4650 times)
ranrang
Newbie
*

Karma: 1
Posts: 12


View Profile
« on: January 07, 2012, 01:07:44 AM »

Hi,
Two issues:
a) did anyone managed to run the Wi-Fi in WPA? I coudn't set it up using WPA_* or etc/../interfaces.
b) I managed to use the Bluetooth, but after boot it seems you have to reload everything (I used init..RC2, similar to 8787 with all the required stuff).

Thanks, Ran
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #1 on: January 08, 2012, 09:16:48 PM »

a) do you have try to used WPA_SUpplicant or some ubuntu wireless mangment package , just like Wicd...
b) I did't understand your mean, if your mean that you want to used script to do "insmod bluetooth...", just like wireless to do , you could add you want at /etc/init.d/8787 script
Logged

ranrang
Newbie
*

Karma: 1
Posts: 12


View Profile
« Reply #2 on: January 08, 2012, 11:28:54 PM »

a) I tried WPA_Supplicant, and I also tried define it under /etc/network/interfaces, but none worked.
b) I used similar script as 8787 to run load Bluetooth. However, it was not effective, as Bluetooth was not up after booting, and I had to enter the initialization commands sequence to run it. There was a comment, though, in 8787 that there might be a problem due to internal processes that could'nt finish at time of init invocation, thus you may not be able to initialze Bluetooth at init. I am looking for someone who managed to do it - and tell me how.
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #3 on: January 09, 2012, 08:29:51 PM »

a) so do you mean , you only has issue at WPA mode , if AP config to open-system none security , you will work fine right
b)for bluetooth, I have try at my site, it work fine , Ihave attach my init script for your reference

* 8787 (2.04 KB - downloaded 257 times.)
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #4 on: January 11, 2012, 04:12:14 AM »

a) wireless issue , my D2Plug also has similar issue , I found this is beacuse ,if you used WPA_supplicant ..the ubuntu network-mangment will interference it

so there are hard to connect AP , I stop ubuntu  network-mangment  through command "sudo /etc/init.d/network-mangment stop" than try  WPA_supplicant 
again it work , I could connect AP
Logged

ranrang
Newbie
*

Karma: 1
Posts: 12


View Profile
« Reply #5 on: January 11, 2012, 04:48:06 AM »

I'll try both sugestions later (probably this weekend) and let you know. Thanks
Logged

ranrang
Newbie
*

Karma: 1
Posts: 12


View Profile
« Reply #6 on: January 14, 2012, 10:55:59 AM »

OK, I managed to work. But it was crazy - and there is one important lesson...

The wpa_supplicant was configured by looking at the "wpa_supplicant -Dwext -imlan0 -c/etc/wpa_supplicant.conf -dd" results (important - use the -dd to see what happens), while playing with various parameters in the wpa_suppliant.conf file.

Eventually, I managed to see with iwconfig the hidden  ESSID I used (in the .conf you have to say ap-scan=2), and the end result, in my AP setting, was:

ctrl_interface=/var/run/wpa_supplicant
ap_scan=2

network={
        ssid="name of access-point"
        psk="ascii-string of wpa string"
        key_mgmt=WPA-PSK
        proto=WPA RSN
        pairwise=CCMP TKIP
        group=TKIP
}

Then, I made wpa_supplicant run at boot (write a script and put it in init.d, then update-rc), but do not forget to add -D to the wpa_supplicant command (for daemon).

Then - I saw the mlan0 in ifconfig (dhcp address) and in iwconfig (with the right ESSID) - but mlan0 did not work. Every time I pulled eth0 out of the LAN - the wireless (mlan0) did not work (despite the fact it had IP address and an assigned ESSID).
Half a day went, and then, I plugged the eth0 out, and booted. Only then, the mlan0 started to work...

As for the bluetooth, it was a stupid error in the RC.2/SXXX loading sequence. You have to use for start:
        modprobe bluetooth
        insmod /lib/modules/bt8xxx.ko
        /etc/init.d/network-manager restart

Now, if anyone can tell me how to set things more easily to turn the mlan0 into an AP (there is some READing to do in
/usr/src/linux-headers-2.6.32.9-dove-5.4.2/Documentation/networking/mac80211... anf I'm not sure how much this is relevant.

Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #7 on: January 15, 2012, 08:21:49 PM »

I have a little bit confuse ,
1.your AP mean you want to do the AP mode ?
2. your bluetooth is working fine right?
3.as I previous suggestion ,ubuntu networking-mangment will interference WPA_Supllicant , do you try stop it first
Logged

ranrang
Newbie
*

Karma: 1
Posts: 12


View Profile
« Reply #8 on: January 16, 2012, 06:34:47 AM »

1. Yes. Right now I am using it as a client. My question is how to make it AP - and how to enable routing of other Wireless clients throgh the d2plug's eth0 connection.

2. the bluetooth is fine.

3. I tried. It seemd that the network connection I am booting from (wireless or eth0) stays untill I'm booting again. Does your d2 switch betweeen eth0 and mlan0 once you plug eth0 out of the switch?
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #9 on: January 16, 2012, 09:00:53 PM »

1. could you let me know the detail ,why you need AP mode , I afraid ,even AP mode isworking , but still not met your requirment
2. I used NFS mode so eth0 still has connection , I stop ubuntu network-mamgment than used WPA-Supplicant connect to AP , and used sudo dhclient mlan0 command  form console to get IP , so I think it work
Logged

Pages: [1]
Print
Jump to: