• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1] 2
Author Topic: D2Plug - voice is chopping/slowdown when backlight power down  (Read 7422 times)
kstaniek
Newbie
*

Karma: 2
Posts: 17


View Profile
« on: November 24, 2011, 06:40:25 AM »

Hi,

I have installed mpd and configured for pulseaudio. My audio receiver is connected to SPDIF but the problem is observed also on the earphone analog output.

The audio starts chopping and slowing down after certain amount of time.
I correlated it with following log message:
D2Plug kernel: [  630.602506] backlight power down

This error message is generated by dove_bl.c in kernel as I could grep out.

It happens even when gdm is stopped.

How to prevent it?
Cheers,
klaus
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #1 on: November 24, 2011, 08:21:21 PM »

I nou used MPD before

could you let me know your used case through network, local ... due to mpd is a dameon so if you play at local whcih player play it

BTW prevent it I think you could tuen off SCreen Saver at System->SCreen Saver and some monitor setting at power mangiment at System->power mangerment

another thing you need to check is when you play vedio (for exapmle type totem <vedio name> at consloe or x-terminal), you could see some word like "vmeta" at console , you have this word mean you have get hardware accerlate

Logged

kstaniek
Newbie
*

Karma: 2
Posts: 17


View Profile
« Reply #2 on: November 26, 2011, 03:17:59 PM »

Anyone from Marvel can explain how the power management is implemented on D2plug?
How to prevent the system of going to idle state?
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #3 on: November 27, 2011, 07:53:35 PM »

I think system into idle state is base on user setting at ubuntu system , do you used I post method to trun off power mangment and screen saving than give a try
Logged

kstaniek
Newbie
*

Karma: 2
Posts: 17


View Profile
« Reply #4 on: December 04, 2011, 05:24:08 PM »

When the screen is blanking then the PMU goes into Deep-Idle mode and the sound starts chopping.
The arch/arm/mach-dove/pm.c modification forcing the PMU to stay in eBook mode (whatever it means) when screen is blanking prevents of getting into sound problems.

It was probably assumed that blanking screen should disable the sound output on HDMI and which is actually happening.
But there are also S/PDIF and Analog outputs that should not be affected.

Anyone from Marvel can comment on this?


Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #5 on: December 07, 2011, 04:19:09 AM »

but I think is not marvell issue

it is unbuntu power mangement behavior

you could look below post, it since someone used ubuntu system also facing same issue

http://askubuntu.com/questions/2388/screen-power-management-during-media-use
Logged

kstaniek
Newbie
*

Karma: 2
Posts: 17


View Profile
« Reply #6 on: December 07, 2011, 05:56:39 AM »

I really appreciate you want help but in my first post I wrote that it happens when gdm is stopped.
My D2Plug is headless. I don't run GNOME nor KDE. No screensaver. The Caffeine application is just an applet which helps you when you watch flashvideo or play the games to prevent the screensaver activation. I've got similar application on my Mac.

The problem is related to power management functionality implemented in kernel for mach-dove/plat-orion architectures.
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #7 on: December 07, 2011, 09:11:22 PM »

I find another coomand , maybe useful , "setterm"

try "setterm -blank 0" and "setterm -powersave off"

your could try it , as I mention before I don't have your enviroument, so I can't make sure this also working on you

BTW , as I know monitor also have power saving mode ,if this is device into power saving mode cause , I think you also can't hear any voice form S/PDIF , but your case is could hear voice form S/PDIF ,HDMI not , so maybe this is monitor behavior
Logged

kstaniek
Newbie
*

Karma: 2
Posts: 17


View Profile
« Reply #8 on: December 08, 2011, 05:08:50 AM »

Sorry, but it's not useful at all.

The problem is related to Deep-Idle mode implementation in Kernel and needs to be fixed with kernel patch.

Waiting for guys from Marvell for commenting....
Logged

mentor
Jr. Member
**

Karma: 2
Posts: 67


View Profile
« Reply #9 on: December 08, 2011, 08:00:31 PM »

if you think it belong to deeplide mode

another way could resolve it, you could add "pm_disable" at boot args for uboot neviroument parmenter , this way could disable kernel deepidle function
Logged

Hell-G
Newbie
*

Karma: 2
Posts: 13


View Profile
« Reply #10 on: January 06, 2012, 11:55:08 AM »

Hello!

I had a similar issue on my D2plug. I just recently got it and it is running Ubuntu 10.04.3 LTS with a 2.6.32.9-dove-5.4.2 kernel. After an initial apt-get update && apt-get upgrade, one of the first things was to install MPD. I was not satisfied with the included version 0.15.4 as I had distorted playback. My symptoms are similar to yours, but I cannot tell if it has something to do with a graphical idle mode, as my plug is headless.

So I installed MPD version 0.16.6 from source. It did not change anything. But then I realised that this only happend for mp3 files. Flac and ogg played just fine. So I recompiled and disabled MAD, which I guess was decoding the mp3 files, and enabled mpg123.
With this replacement my mp3 playback is now just fine!

mpd (MPD: Music Player Daemon) 0.15.4
Supported decoders:
[mad] mp3 mp2

mpd (MPD: Music Player Daemon) 0.16.6
Supported decoders:
[mpg123] mp3

The following version of MAD is installed with this Ubuntu:
libmad0/lucid uptodate 0.15.1b-4ubuntu1

Maybe you can check if you also have a problem with MAD.

You wrote that you are using pulseaudio and SPDIF. This is also my setup, but I don't get any sound on my SPDIF. Can you tell me how you configured pulseaudio/mpd to get sound on the SPDIF? Thanks!

Greetz
Logged

kstaniek
Newbie
*

Karma: 2
Posts: 17


View Profile
« Reply #11 on: January 06, 2012, 12:23:40 PM »

I can confirm that recent version of MAD lib is not working correctly and eventually I compiled MPD without MAD support and use mpg123 instead. That was the first problem I came across with my D2Plug wanted to run MPD.

In terms of MPD configuration here is the relevant snipplet from mpd.conf
Code:
audio_output {
        type            "pulse"
        name            "Headphone"
        sink            "alsa_output.platform-soc-audio.0.analog-stereo"   
}

audio_output {
        type            "pulse"
        name            "Amplituner"
        sink            "alsa_output.platform-soc-audio.1.analog-stereo"
}

Headphone is obviously analog jack output and Applituner is SPDIF connected to my home audio set.

Any other audio_outputs are commented in my conf file.
The PA configuration is just default and I haven't changed anything as far as I remember.

It works fine now for me however I altered the pm.c to ignore deep-idle mode and recompiled the kernel.
If you come to that point I'll share more details if needed.

If you have any chance to connect any display to the plug you can check the audio under gnome. There is applet allowing selection of the default sound output. Anyway the configuration of MPD is independent of the configuration of gnome. That is a drawback that changing the volume under gnome I have no control on the volume of music played by MPD. This is not affecting my setup as my plug is also headless.

good luck and do not hesitate to ask if you have more question. I'm fine with sharing me experience.
Logged

Hell-G
Newbie
*

Karma: 2
Posts: 13


View Profile
« Reply #12 on: January 08, 2012, 06:09:12 AM »

Thanks for your hints and config settings!

I think I'm not suffering from problems with deep idle. But in case, I know who to ask  Smiley

I guess I was confused by the descriptions of the pulseaudio sinks. I thought that sink 1 is only for audio over hdmi. So I tried to disable sink 1 and only use sink 0. But I will try your settings.

Code:
name: <alsa_output.platform-soc-audio.0.analog-stereo>
device.description = "D2PLUG-I2S0-AUDIOJACK Analog Stereo"

name: <alsa_output.platform-soc-audio.1.analog-stereo>
device.description = "D2PLUG-I2S1-HDMI Analog Stereo"

The only thing I changed in pulseaudio was making sure that sink 0 was default for all users. But at that moment I only had access to a stereo with audio jack. I will check SPDIF tonight.
Logged

kstaniek
Newbie
*

Karma: 2
Posts: 17


View Profile
« Reply #13 on: January 08, 2012, 06:38:37 AM »

Indeed that might be confusing. Based on my testing SPDIF (Tonsil) and HDMI is the same sink.
Logged

Hell-G
Newbie
*

Karma: 2
Posts: 13


View Profile
« Reply #14 on: January 08, 2012, 04:26:53 PM »

It works!

Thanks a lot!!!
Logged

Pages: [1] 2
Print
Jump to: