• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Problems installing ziproxy  (Read 1890 times)
nicom
Guest
« on: September 09, 2011, 04:14:24 PM »

I have just taken delivery of a Sheevaplug with the intention of using it as a proxy server at home and to allow remote adjustments to the recording scheduling on HTPC (LinHES). My intention is to stick with the standard Ubuntu 9.04 OS and not use external storage (card or disk) other than the other computers on the home network. I performed the modifications as described in the wiki to get it working.

My next step was to install a proxy. From reading this forum it looked like ziproxy is a good option as it is non-caching which I assume is better for my low memory system. Trying "apt-get install ziproxy" could not find anything. "apt-get update" could not find anything. I then modified /etc/hosts and commented out the line "91.189.88.36 ports.ubuntu.com". "apt-get update" successfully update the lists. "apt-get install ziproxy" was able to copy over the ziproxy_2.5.2-2_armel.deb and libgif4_4.1.6-6_armel.deb files but could not find 3 other packages, namely:

libjpeg62_6b-14_armel.deb
libjasper1_1.900.1-5.1_armel.deb
libpng12-0_1.2.27-2ubuntu1_armel.deb

I then googled these 3 files and found the first two at http://160.26.2.181/ports/pool/ but I could find no trace of the last one. Therefore I cannot complete the installation by apt-get. Since I do not have the option of reinstalling the OS if I stuff it up, I am being very cautious about what I do.

What I cannot understand is that when I do a "apt-cache depends privoxy" I get

Code:
root@debian:/# apt-cache depends privoxy
privoxy
  Depends: libc6
  Depends: libpcre3
  Depends: zlib1g
  Depends: logrotate
  Depends: adduser
  Recommends: doc-base
root@debian:/#
All of these packages are present and none of the ones I cannot get are listed.

Has anyone recently had success loading ziproxy?
If so how do I get the missing dependencies?
If not, are there any other proxies worth trying? tinyproxy?
Should I stick with a heavier one such as privoxy?
Logged

nicom
Guest
« Reply #1 on: September 24, 2011, 11:35:04 PM »

If anyone is interested I managed to get ziproxy installed. What I did was download the files libjpeg62_6b-14_armel.deb
and libjasper1_1.900.1-5.1_armel.deb from the site I mentioned. I also downloaded libpng12-0_1.2.27-2ubuntu2_armel.deb
instead of the missing libpng12-0_1.2.27-2ubuntu1_armel.deb and then changed the name to libpng12-0_1.2.27-2ubuntu1_armel.deb. I then copied these 3 files to /var/cache/apt/archives on the plug. I tried "apt-get install ziproxy" but it still failed to find the libpng file so I recopied the .deb file to  plug and installed libpng with "dpkg -i libpng12-0_1.2.27-2ubuntu1_armel.deb". After that "apt-get install ziproxy" worked fine and ziproxy is running as indicated by top.

I have not been able to test whether it successfully tunnels an internet connection yet. I will try that during the week.
Logged

nicom
Guest
« Reply #2 on: September 26, 2011, 08:08:25 PM »

Well, I can successfully tunnel through from a remote windows machine with putty. The response is very slow and image quality is low. I will try playing with some of the settings in the /etc/ziproxy/ziproxy.conf to see if I can improve performance.
Logged

Pages: [1]
Print
Jump to: