• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Change transmission download directory to USB stick?  (Read 4577 times)
billybob
Newbie
*

Karma: -1
Posts: 16


View Profile
« on: September 13, 2011, 04:44:19 PM »

I have mounted a fat32 USB stick on my sheevaplug using:

mount -t vfat /dev/sda1 /mnt/usbstick

when I change the transmission torrent download directory to /mnt/usbstick I get an access denied error.

I know virtually nothing about linux and don't understand why it will not write to it. Do I need a different path to that directory or change the read/write status?

I just want to be able to download files and then transfer the stick straight into a windows machine. Any help would be great?
Logged

billybob
Newbie
*

Karma: -1
Posts: 16


View Profile
« Reply #1 on: September 14, 2011, 04:27:18 AM »

I tried changing permissions on the download directory to 777 but made no difference.
The I noticed the original download directory is labelled drwsrwxrwx. I do not understand how to replicate this on the new directory. Something to do with the group it belongs to?
Why didn't I lsten n my computer studies lectures. The only command I ever remembered was ls -lasig ad at least I actually got to use that here even though I have no idea what it means.
Logged

cbxbiker61
Global Moderator
Sr. Member
*****

Karma: 38
Posts: 497


View Profile
« Reply #2 on: September 14, 2011, 04:58:29 AM »

Did you type "mount" to verify your stick is mounted read/write?

Can you copy a file to the stick from the command line?

It's certainly possible that transmission is trying to do something, like set file permissions, that is not valid on a FAT partition and is failing.  So check that transmission is actually able to work with a FAT partition.
Logged

billybob
Newbie
*

Karma: -1
Posts: 16


View Profile
« Reply #3 on: September 14, 2011, 05:20:25 AM »

Just checked that and seems to be fine:

debian:~# mount -t vfat /dev/sda1 /mnt/USBstick
debian:~# mount
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
rootfs on / type rootfs (rw)
/dev/sda1 on /mnt/USBstick type vfat (rw)

Files copy fine to the drive and there appear to be plenty of people using transmission to write to FAT32. Probably why I am so annoyed that I can't make it work.
Logged

leighbb
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #4 on: September 14, 2011, 06:19:33 AM »

Is transmission running as root?
Logged

billybob
Newbie
*

Karma: -1
Posts: 16


View Profile
« Reply #5 on: September 15, 2011, 01:35:01 AM »

No it is running as user 'transmission'
Logged

leighbb
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #6 on: September 15, 2011, 04:02:05 AM »

In which case, it may be that the transmission user does not have permissions to write to the filesystem (vfat has no inherent protection so by default it only allows writing by the root user).

You could try using the uid=n and gid=n options to specify the uid and gid of the transmission user, when mounting.

e.g.
Code:
mount -t vfat -o uid=1000,gid=1000 /dev/sda1 /mnt/USBstick

(assuming the tranmission uid and gid was 1000)
Logged

billybob
Newbie
*

Karma: -1
Posts: 16


View Profile
« Reply #7 on: September 15, 2011, 05:40:09 PM »

Thanks, you are spot on. Trouble is I didn't get what the uid and gid was? The only way I could work it out was to change the transmission user to ROOT. That way all the permissions are correct and at last it works.
Logged

leighbb
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #8 on: September 16, 2011, 12:39:06 AM »

I would highly recommend you do NOT run transmission as root.

You can work out the uid and gid by running "id transmission", and making a note of the uid and gid numberic values.  I don't have transmission but here is an example using the postfix user.

Code:
kettle /home/leigh $ id postfix
uid=51(postfix) gid=51(postfix) groups=51(postfix)
Logged

Pages: [1]
Print
Jump to: