• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: openocd won't work  (Read 1208 times)
Catscrash
Newbie
*

Karma: 0
Posts: 10


View Profile
« on: June 15, 2011, 03:58:06 PM »

hi

i erased my uboot in the process of upgrading it and then the power went off before i could rewrite the new one... now it won't boot up again, so i tried that: http://plugcomputer.org/plugwiki/index.php/Reflashing_images_on_the_GuruPlug#Flashing_U-Boot_on_Bricked_Plug

unfortunately i seem not to be able to get it done

Code:
sudo ./runme.sh openocd/uboot.bin
cp: „openocd/uboot.bin“ und „openocd/uboot.bin“ sind die gleiche Datei
 ****     Preparing environment variables file ...
 ****   Burning uboot and environment variables ... This will take few minutes ...
Open On-Chip Debugger 0.2.0-in-development (2009-05-17-10:32) svn:1800M


BUGS? Read http://svn.berlios.de/svnroot/repos/openocd/trunk/BUGS


$URL: http://svn.berlios.de/svnroot/repos/openocd/trunk/src/openocd.c $
2000 kHz
dcc downloads are enabled
Info : JTAG tap: feroceon.cpu tap/device found: 0xfc0000e3 (Manufacturer: 0x071, Part: 0xc000, Version: 0xf)
Error: JTAG tap: feroceon.cpu             got: 0xfc0000e3 (mfg: 0x071, part: 0xc000, ver: 0xf)
Error: JTAG tap: feroceon.cpu expected 1 of 1: 0x20a023d3 (mfg: 0x1e9, part: 0x0a02, ver: 0x2)
Error: trying to validate configured JTAG chain anyway...
Warn : value captured during scan didn't pass the requested check:
Warn : captured: 0x00 check_value: 0x01 check_mask: 0x0F
Warn : no telnet port specified, using default port 4444
Warn : no gdb port specified, using default port 3333
Warn : no tcl port specified, using default port 6666
Error: unknown EmbeddedICE version (comms ctrl: 0x00000018)
Error: timed out while waiting for target halted
Runtime error, file "./openocd/./board/guruplug.cfg", line 24:
   
 ****   openocd FAILED
 ****   Is the mini USB cable connected?
 ****   Try powering down, then replugging the Sheevaplug

i read that the timing is important so i tried plugging the power in at about a hundred different timings, but it's not really working... any tips?

thanks
Logged

Pages: [1]
Print
Jump to: