• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: iwconfig kernel oops  (Read 6274 times)

Karma: 0
Posts: 12

View Profile
« on: April 09, 2011, 02:03:14 AM »

Brand new DreamPlug freezes after switching into wlan client mode per http://tinyurl.com/4yonjo3. If you try to run iwconfig, ifconfig, etc .. they all hang. dmesg shows a the kernel being unhappy

Steps to reproduce

1) /sbin/wlan.sh
2) iwconfig (with any valid option)
... iwconfig segfauls ...

Unable to handle kernel NULL pointer dereference at virtual address 00000090
pgd = de630000
[00000090] *pgd=1e73a031, *pte=00000000, *ppte=00000000
Internal error: Oops: 80000005 [#1] PREEMPT
last sysfs file: /sys/devices/platform/leds-gpio/leds/guruplug:red:health/brightness
Modules linked in: sd8xxx mcypt(P) btmrvl_sdio btmrvl xt_tcpudp iptable_filter ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 ip_tables x_tables bridge stp llc bnep sco rfcomm l2cap dm_crypt dm_mod ipv6 snd_usb_audio snd_pcm snd_page_alloc snd_hwdep snd_usb_lib snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device snd sata_mv soundcore bluetooth mv_cesa [last unloaded: uap8xxx]
CPU: 0    Tainted: P            ( #1)
PC is at 0x90
LR is at get_wireless_stats+0x60/0x6c
pc : [<00000090>]    lr : [<c03b7ff4>]    psr: 20000013
sp : de593db0  ip : de593dc0  fp : de593dbc
r10: df2b43a0  r9 : 00000001  r8 : 00008b0f
r7 : de593eb0  r6 : de593eb0  r5 : df2b43a0  r4 : 00008b0f
r3 : 00000090  r2 : de46b000  r1 : de593e54  r0 : de46b000
Flags: nzCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
Control: 0005397f  Table: 1e630000  DAC: 00000015
Process iwconfig (pid: 2449, stack limit = 0xde592270)
Stack: (0xde593db0 to 0xde594000)
3da0:                                     de593ddc de593dc0 c03b8060 c03b7fa8
3dc0: 00008b0f de593ea0 c040e264 de593eb0 de593e44 de593de0 c03b888c c03b8058
3de0: de593e54 de46b000 00000020 00000000 c0035f34 c0039a28 00000000 de58b4f8
3e00: 00000001 00000001 00000004 60000013 c05fa518 de593ea0 c05fa518 00008b0f
3e20: de593ea0 c05fa518 beb8fe04 00000001 00000000 de593ea0 de593e7c de593e48
3e40: c03b81ac c03b85f8 c03b8048 de593e58 c02339b0 00008b0f 00000002 de592000
3e60: 00008b0f beb8fe04 00000000 c05fa518 de593ef4 de593e80 c03166ac c03b80b0
3e80: de593eac de593e90 de593eac de593e98 c00547ec c03dc93c 00000000 de58b4f8
3ea0: 6e616c6d 00000030 00000000 00000000 beb8ffa8 00010020 00000003 beb8fe60
3ec0: a0000013 c05f5940 de593ef4 de58d880 beb8fe04 00008b0f de58d880 beb8fe04
3ee0: de592000 beb8ffcc de593f14 de593ef8 c00b20f4 c0315f68 de58d880 df649028
3f00: 00008b0f de58d880 de593f7c de593f18 c00b27e4 c00b20d0 00000000 df60cd00
3f20: df60ac30 00000023 de592000 beb8d758 de593f6c de593f40 c00a4cc0 c00d2a30
3f40: 00000000 00000000 c020e2dc 00000000 00000000 de6ab000 00000003 beb8fe04
3f60: 00008b0f de58d880 c002bbc4 beb8ffcc de593fa4 de593f80 c00b287c c00b2284
3f80: ffffffff 00000000 beb8fe04 00000003 beb9073f 00000036 40035000 de593fa8
3fa0: c002ba40 c00b284c beb8fe04 00000003 00000003 00008b0f beb8fe04 beb8fe13
3fc0: beb8fe04 00000003 beb9073f 00000036 00000000 00000003 beb8ffcc 40035000
3fe0: beb8fe60 beb8fcf8 4002a2d0 401a477c 60000010 00000003 00a09031 00a09431
Code: bad PC value
---[ end trace 8b947137d269272e ]---

Any ideas or newer kernel images that fix this?

Kernel Version : Linux ubuntu #1 PREEMPT Tue Feb 8 03:18:41 EST 2011 armv5tel GNU/Linux


Karma: 0
Posts: 1

View Profile
« Reply #1 on: April 09, 2011, 04:44:14 PM »

I see the same problem with my new Dream Plug.  Also,

in the WIKI and in the link posted by tomasz, it talks about using wpa_supplicant with "wlan0".  This does not work, as the new interface "mlan0" is created (not "wlan0").


Karma: 2
Posts: 26

View Profile WWW
« Reply #2 on: April 13, 2011, 05:28:27 AM »

I am getting the same with the Ubuntu from the Download area.
I have the tried the Kernel & Modules that came with the prerelease plugs(Debian Lenny) loaded onto Ubuntu and they work fine.

Linux version (root@localhost.localdomain) (gcc version 4.2.0 20070413 (prerelease) (CodeSourcery 2007q1-10. Marvell 2008q3-13 20081204)) #1 PREEMPT Sun Dec 5 22:56:10 CST 2010


Karma: 0
Posts: 12

View Profile
« Reply #3 on: April 20, 2011, 08:08:24 PM »

I've mailed GlobalScale about this so we'll see what they say. I'd happily try a newer kernel out but without a jtag box i'm not willing to risk bricking it.

Jr. Member

Karma: 1
Posts: 61

View Profile
« Reply #4 on: April 22, 2011, 08:12:44 AM »

I have been able to switch to client mode and run fine, but I get the kernel oops if I run iwconfig.  I'm running the kernel from Google code and an updated Squeeze.

Full Member

Karma: 8
Posts: 167

View Profile WWW
« Reply #5 on: April 22, 2011, 03:58:27 PM »

The crash looks very similar to the one that I was experiencing with a SheevaPlug and USB wifi until cured the problem.

Same path to a crash. has been very stable for me.


Karma: 0
Posts: 12

View Profile
« Reply #6 on: April 25, 2011, 12:50:34 AM »

Looks like (http://plugcomputer.org/plugforum/index.php?topic=5799.0) is out which might fix this. Sadly the upgrade requires a change to the uBoot env. Does anyone know if there is a way to do that if you don't have a JTAG ?

Pages: [1]
Jump to: