• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: My experience with the GuruPlug+  (Read 2897 times)

Karma: 0
Posts: 1

View Profile
« on: February 24, 2011, 08:48:01 PM »

Hello all.  I have been lurking here for quite some time, since I considered purchasing the GP, and thought I might share my experiences with it.

This will be a personal journal of sorts, and can be very long winded (you've been warned!), but it may answer some questions for others.

I ordered my GP from GlobalScale.  It took over 2 months to receive it.  When the 2 month mark hit, I emailed them to see what was going on.  My first email went unanswered, and so I both called them and I sent a follow-up email a week later.  I received a response from the second email and my product was shipped a week after that.  The website stated 4 weeks before the product was to be shipped, and I payed the extra for expedited shipping, so I wasn't very happy with it taking so long to be sent out.

My main intention for the GP is to use it as a file server.  The GP has been running for a few months now without a hiccup.  I believe the system is very solid.

Network setup:

I run a gig network through my house with a Netscreen hanging off of the cable modem providing access for two separate networks.  There is a 5-port gig switch hanging off of the NS FW, and a BSD box to provide additional packet filtering for the "home" network (iptables).  There is an 8 port gig switch hanging off that BSD box.  There's an additional 5 port gig switch on each network as well.  There are NMS servers on the other side, and the "home" network has our entertainment devices plugged into it; WDTVLive, HTS, and the Tivo.  There's a Wireless N to provide wireless access for the laptops and the Wii.

The WDLive has a 1.5Tera WD USB external HDD plugged into it.  I moved that over to the GP; shared via Samba to the WDLive

For whatever reason, sharing USB across the network from the GP is less than optimal.  I receive a read transfer rate of 3-4MB/s.  Very low.  I have tried other USB devices, including USB memory sticks, and always receive the same transfer speed.  I have also tried sharing via HTTP/FTP/NFS and still the same transfer speed.  Reading the same device from any system, including the GP, yields a much higher performance reading.  It's not the network either, as the system shared via eSata does not display the same issue.  It has to be something with the GP, something I plan to look more into later, as my streams to the WDLive are not affected it's not a top priority.

I use a Sans Digital MS2UT RAID enclosure with 2x1TB WD black HDDs in RAID1 with ext4 for backups plugged into the GP via eSATA; shared via Samba to laptops, and NFS to the BSD server.

I am quickly running out of space on the MS2UT, and so decided to purchase a higher capacity unit to replace it; the MS2UT will be plugged into the TiVO for additional DVR storage space, and will be reconfigured for RAID0.

I purchased a Sans Digital TR5M with 5 1TB HDDs, received today, as the MS2UT has been rock solid.  To my dismay, the new unit does not have a built-in RAID controller. 

I will not use the garbage RocketRaid card sent with the TR5M, and not like I could insert it into the GP anyhow, and figured I would try linux software raid with the GP... If the eSATA port support port-multiplier...

The GP DOES support port-multiplier! Score!  I plugged in the TR5M to the GP and all 5 HDD lights lit up. 

If the eSATA port did not support port-multiplier, only the 1st HDD light would have lit on the unit, and only the 1st HDD would have been accessible to the system.

I am currently formatting the RAID, approximate time is 8 hours until completion, so I do not yet know how performance will be.

The setup of the TRM5 is 4 active HDDs in RAID5 and a single spare, with 512k chunk size, and using a 4k-block ext4 FS.  All 5 HDDs are the exact same WD Black 1TB HDDs.

I have an 8GB class 6 misco-USB flash card to shove into the GP and will be installing Debian squeeze on the card, as I have run out of space on the device itself ( / is 98% full).

Since I have about 50Gig of music I am utilizing mysql on the GP, I just started the setup of this application, with some homebrew scripts, to categorize my music collection.  I will write about the performance of mysql being utilized on the system after I start dumping data.

Jr. Member

Karma: -1
Posts: 56

View Profile
« Reply #1 on: March 20, 2011, 04:30:45 PM »

Wondering how it's going some weeks in. How is the Sans Digital TR5M working out. Did Raid work on your plug w/o the port multiplier? I want to add a raid enclosure to my Plug setup and would appreciate the feedback.

Currently, I've been running a std SheevaPlug with a USB hub and one external 1.5TB hdd. I have lots of things running on it, and it has been trouble-free (fingers crossed). I'm about ready to go next gen with a guruplug or newer to get the eSata support, but I do want/need a proper hdd enclosure. Needs to support raid and be hot-swappable w 4-5 bays.


Pages: [1]
Jump to: