• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Adventures in Sheevaplug modding (eSATA)  (Read 4011 times)

Karma: 0
Posts: 3

View Profile
« on: March 10, 2011, 08:25:20 PM »

I modified my v1.3 Sheevaplug as shown on Mark's blog (http://mark.ossdl.de/2010/04/howto-extend-the-sheevaplug-by-esata/), and all seemed to go well. I ended up omitting the .1uF caps on the power filter to the eSATA logic in the SoC. Mark seemed to indicate this would be ok.

uBoot 3.4.27 from the KuroPlug (off Mark's blog above) recognizes that I have power to the eSATA logic. To avoid compiling a custom kernel (just for convenience), I set arcNumber to 2678, that of the eSATA Sheevaplug reference board.

A directly-connected SATA drive (using a eSATA->SATA cord and a wall wart feeding 5V to a SATA power connector) works great. uBoot recognizes the drive, and Debian mounts it. hdparm shows about 80MB/s to a 5400 RPM laptop drive, which is pretty awesome.

However, no external enclosure I've tried is recognized by either uBoot or Debian. I've tried the following:

- A cheap Chinese external 2.5" eSATA enclosure. Doesn't respond to SRST commands. Other folks have said they've run into problems here also.
- A Thermaltake dock that takes a combination of 2.5" and 3.5" drives (2 slots). uBoot and Debian both fail reading PMP registers.
- A 4-bay external eSATA enclosure, takes only 3.5" drives (I forget the brand name). Same symptoms as above.

Since both uBoot and Debian fail on port multiplier stuff, I'm leaning toward a hardware issue, like I've screwed up the hardware mod.

My theories:
- Hardware issue. Both uBoot and Debian fail, but a bare drive works great.
- uBoot issue. No "official" eSATA Sheevaplug image, but others have shown uBoot recognizing their port multipliers just fine. Maybe
- Maybe setting arcNumber to 2678 is a no-no. It seems a little weird that there would be two different arcNumbers for the same hardware, give or take a few capacitors.

If interested, I'll harvest a console dump or uBoot output, but it's late, and I'm not in a position to get that stuff at the moment.

Thanks for any help!

Pages: [1]
Jump to: