• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Not all USBs are created equal  (Read 1615 times)

Karma: 0
Posts: 1

View Profile
« on: January 24, 2011, 02:34:23 PM »

Having just gone through the dreaded dead PSU trauma the following points might be f use to someone.

1.   I reached for the first USB A to mini-B cable that came to hand.  This was from an MP3 player which it will connect to my laptop without problems.  Minicom didn't see anything at the far end of it.  I had to hunt for another USB cable with a better-fitting mini-B.  Who knows - it might even have been the original.

2.  The USB hard drive threw lots of errors when booting.  It worked fine on the laptop.  It would also fsck -c without errors on the Sheeva using the Ubuntu from the Nand.  It also threw errors when using that Ubuntu to unpack the Debian tarball.  It would read & write small files OK; large ones were beyond it.  I decided the new PSU wasn't providing quite enough power when the drive was working hard.

3. I got a cheap hub with external PSU from eBay.  This wouldn't even spin up the drive.  Neither would it spin up the drive when powered through the USB port of the laptop.  The output of the PSU measured 5.02V.  There will be some voltage drop in the regulator inside the hub.  Neither 5.02V in nor whatever the nominal 5V USB supply of the laptop were enough to compensate for this drop.

4.  A Belkin hub with an external PSU worked fine.  Belkin's PSU produced 5.26V.  Everything ran fine until I moved it off the bench to install alongside the ADSL router.  The Belkin hub died.

5.  PC World replaced the Belkin hub with another.  The PSU of this produced 5.24V.  This is now installed and working OK.

To be fair to the eBay vendor they wrote unprompted to say they'd been supplied with the wrong PSU and they'd accept a return.  This came just as I'd got the Belkin hub working.

6.  I tried a number of USB keys to upgrade the uboot.  The plug wouldn't recognise the Sandisk that normally lives on my keyring not a couple of Discgos.  I finally dug out an old Transcend that I'd previously lost.  That worked.

And they say the U in USB stands for Universal.  Don't believe it!


Pages: [1]
Jump to: