• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Plug in SD card - system turns off  (Read 2449 times)
sparsile
Newbie
*

Karma: 0
Posts: 3


View Profile
« on: June 25, 2009, 02:35:18 PM »

Just started fiddling with my plug today and was able to get the basics accomplished - ssh, serial login, webserver downloaded, etc. works like a champ. 

UNTIL I plugged in an 8GB SDHC card. Everything just went dead. All lights out, lost ssh, etc.  When I pull the card out, it reboots.

Any ideas on what is causing this or did I get a defective unit out of the box?
Logged

rooster
Guest
« Reply #1 on: June 26, 2009, 06:23:52 AM »

I would first try to replace the shipped kernel which does not support SDHC, the new mainline 2.6.30 was tested with several SDHC cards.
There are compiled version here:
IPV4: http://sheeva.with-linux.com/sheeva/
IPV6: http://sheeva6.with-linux.com/sheeva/

and thanks to cbxbiker61  Wink
Logged

bobnielsen
Newbie
*

Karma: 0
Posts: 9


View Profile
« Reply #2 on: June 26, 2009, 11:42:19 AM »

The shipped kernel works fine with my 4 GB SDHC card (Sandisk).
Logged

Rabeeh Khoury
Administrator
Full Member
*****

Karma: 5
Posts: 218


View Profile
« Reply #3 on: June 27, 2009, 01:20:46 PM »

sparsile - it looks a defect in the box.

Maybe you can try opening the box, disconnecting the cable that connects the two boards from it's two ends, and then hooking it back again.
Few people reported that this solved a non working SDIO (but not a scenario similar to yours).

Please report back if this help.
Logged

restamp
Global Moderator
Sr. Member
*****

Karma: 4
Posts: 273


View Profile
« Reply #4 on: June 27, 2009, 06:58:31 PM »

You are plugging the SD card in face down, right?  (The contacts should be facing up as the card is inserted.)

Does another card cause the same symptoms?
Logged

sparsile
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #5 on: June 30, 2009, 07:15:49 AM »

Thanks for the help. I would like to try the new kernel before opening the plug up to check wiring so I've downloaded the 2.6.30-rc8 image, modules, and config file. Can someone please point me to a good How-To that covers installing a new kernel and associated files. Obviously others have figured it out, but I'm having a hard time determining exactly what to do. In response to another's question, I'll get a different SDHC card (different brand) and try it out. Thanks.
Logged

sparsile
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #6 on: June 30, 2009, 12:49:13 PM »

OK. Saw the README/install script that came with rc8 and it worked fine. BUT, that did not solve the problem. So I took the plug apart and did a disconnect/connect on both ends of the cable. It looks like that helped, kind of. When I now insert the SD, it will still do a sudden power off, but then it reboots while the SD card is still in the slot, so once it reboots, I at least have access to the drive. Previously, it would stay powered off until I removed the SD card. Once the card is in, when I apply inward pressure to it, the machine reboots again. So, it looks like some type of electrical/mechanical HW problem. I'll try another SD card tomorrow and see what that does.
Logged

Pages: [1]
Print
Jump to: