• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: study it  (Read 752 times)
Negocios con futuro
Guest
« on: January 21, 2011, 10:50:12 AM »

I started trying to follow Marvell's README 1.1 instructions. I downloaded the Linux host software support package, unzipped it, but then found that I got an error (not a bzip2 file) when I tried to uncompress Linux Host Filesystem - rootfs.tar.bz2.

So then I just booted the plug and logged in through the USB serial terminal. I got the IP address and logged in via SSH. I added /var/cache/apt/archives/partial to get apt to work. I also had to get DNS to work by enabling the DHCP server's DNS information - just comment out the line 'supercede domain-name-servers' in /etc/dhclient.conf, and run /etc/init.d/networking restart.

I've seen a few messages in the logs like this:
JFFS2 notice: (687) check_node_data: wrong data CRC in data node at 0x048b3000: read 0xab835e7d, calculated 0xb7afc291.

On a couple of occasions the plug has hung completely when connecting a USB device. This appeared to be to do with the electrical connection not being made cleanly rather than any software problem (in one instance I tried to plug in the USB cable upside down). Both devices which caused this problem later connected without issue.

I tried to use a couple of FTDI USB->serial based devices, but no device file was created on connection. There doesn't seem to be a ftdi driver in the kernel, and there seem to be no kernel modules on the filesystem. I can't find any more information about that.

I see that the openplug downloads section has an image called Ubuntu 9.05, but I can't find any commentary as to what it is. I also considered compiling my own kernel, but couldn't find any reference as to whether 2.6.30 (currently at rc1) should work.

I look forward to hearing other people's experiences!
Logged

Pages: [1]
Print
Jump to: