• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Audio & The Sheevaplug  (Read 3171 times)
Trune
Jr. Member
**

Karma: 3
Posts: 70


View Profile
« on: January 08, 2011, 01:51:08 PM »

Hi All,

Im running debian squeeze and im trying to get a cheapo usb dongle to work with it so i can use squeezeslave to play audio using ipeng on the iphone.

I have got a cheap 5.1 usb dongle which shows up as Tenx Technology, Inc. TP6911 Audio Headset.

I have installed alsa-oss to get it working, and i have managed to get an output. However the output is crackly and poor.
I have tried installing alsa-utils to play with the mixer but this stops the alsa-oss working.

Im not sure if the issue is something to do with 48khz sampling or if its just rubbish. Id have no problems buying another one if someone knows another one which i better?

OR does anyone have a working asound.conf which will resolve the cracking issues?

Thanks for any help you can offer.
Logged

dattaway
Jr. Member
**

Karma: 5
Posts: 91



View Profile WWW
« Reply #1 on: January 08, 2011, 02:25:28 PM »

The cheaper usb dongles should have no problems with the usb-audio module.  Newer chipsets often do things differently and don't work well until someone patches the driver.
Logged

Trune
Jr. Member
**

Karma: 3
Posts: 70


View Profile
« Reply #2 on: January 08, 2011, 06:08:55 PM »

I'd struggle to get one any cheaper!

I think it's a configuration issue with sampling rates but don't know enough about Linux to confirm this. Works fine with win7.
I've only got Linux as vmware on a pc so can't test it with ubuntu or anything. Guess I could try a live cd. However it may be related to the fact that to install a mixer I need alsa utils which stops OSS working
Logged

Trune
Jr. Member
**

Karma: 3
Posts: 70


View Profile
« Reply #3 on: January 11, 2011, 04:14:46 PM »

Has anyone ever got this working properly?

I have tried a different USB audio dongle which is confirmed as having no distortion on nas devices but I get distortion. Anyone got any ideas?

I've tried squeezeplay and madplay, both with same results. Both using aoss.

CPU usage is below 10%.

Can I made sound support native somehow?
Logged

Trune
Jr. Member
**

Karma: 3
Posts: 70


View Profile
« Reply #4 on: January 14, 2011, 12:43:54 PM »

Yesss! Sorted It.

Massive thanks to a post over at Doozan by PeterGunn. He has solved my issues as well as his own Smiley
http://forum.doozan.com/read.php?2,2840,3071

Here is what he done

Created /etc/asound.conf with the following configuration;
Code:
pcm.!default {
    type plug
    slave.pcm "softvol"
}
pcm.dmixer {
       type dmix
       ipc_key 1024
       slave {
           pcm "hw:0"
           period_time 0
           period_size 4096
           buffer_size 131072
           rate 50000
       }
       bindings {
           0 0
           1 1
       }
}
pcm.dsnooper {
       type dsnoop
       ipc_key 1024
       slave {
           pcm "hw:0"
           channels 2
           period_time 0
           period_size 4096
           buffer_size 131072
           rate 50000
       }
       bindings {
           0 0
           1 1
       }
}
pcm.softvol {
       type softvol
       slave { pcm "dmixer" }
       control {
           name "Master"
           card 0
       }
}
ctl.!default {
    type hw
    card 0
}
ctl.softvol {
    type hw
    card 0
}
ctl.dmixer {
    type hw
    card 0
}

and edit  /etc/modprobe.d/alsa-base.conf

change this line from;
Code:
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

to;
Code:
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=0

Reboot, and perfect sound using

aoss ./squeezeslave localhost

Brilliant, im really pleased. Controlling it using ipeng on the iphone and it sounds pretty good.
Logged

Brandt
Newbie
*

Karma: 0
Posts: 38


View Profile
« Reply #5 on: January 14, 2011, 05:31:53 PM »

Yesss! Sorted It.

Massive thanks to a post over at Doozan by PeterGunn. He has solved my issues as well as his own Smiley
http://forum.doozan.com/read.php?2,2840,3071

Here is what he done

Created /etc/asound.conf with the following configuration;
Code:
pcm.!default {
    type plug
    slave.pcm "softvol"
}
pcm.dmixer {
       type dmix
       ipc_key 1024
       slave {
           pcm "hw:0"
           period_time 0
           period_size 4096
           buffer_size 131072
           rate 50000
       }
       bindings {
           0 0
           1 1
       }
}
pcm.dsnooper {
       type dsnoop
       ipc_key 1024
       slave {
           pcm "hw:0"
           channels 2
           period_time 0
           period_size 4096
           buffer_size 131072
           rate 50000
       }
       bindings {
           0 0
           1 1
       }
}
pcm.softvol {
       type softvol
       slave { pcm "dmixer" }
       control {
           name "Master"
           card 0
       }
}
ctl.!default {
    type hw
    card 0
}
ctl.softvol {
    type hw
    card 0
}
ctl.dmixer {
    type hw
    card 0
}

and edit  /etc/modprobe.d/alsa-base.conf

change this line from;
Code:
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

to;
Code:
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=0

Reboot, and perfect sound using

aoss ./squeezeslave localhost

Brilliant, im really pleased. Controlling it using ipeng on the iphone and it sounds pretty good.



Do you understand what you are doing? We shouldnt even need this I don't know why it doesn't work without it though...pretty lame.

I have been using an ".asoundrc" file in the root's home directory with a huge buffer, other wise the audio starts to crackle like yours....but with a huge buffer it takes forever to load up the audio before it starts playing:

Code:
root@haplug:~# cat .asoundrc
pcm.!default {
type  plug
slave.pcm "ossmix"
}

pcm.ossmix {
   type dmix
    ipc_key 1024
    slave {
    pcm "hw:0,0"
        period_time 0
        period_size 1024
        buffer_size 232072 # buffer size < 6653, but pow(x, 2)
        rate 44100 # we want to play CDs only
        format S16_LE # needed in alsa 1.0.10 for some reason
    }
}
ctl.!default {
type hw
card 1
device 0
subdevice 0
}



I had just commented out the line in the alsa conf file:

Code:
# Keep snd-usb-audio from beeing loaded as first soundcard
#options snd-usb-audio index=-2


I'll try your settings tonight and report back.
Logged

Trune
Jr. Member
**

Karma: 3
Posts: 70


View Profile
« Reply #6 on: January 15, 2011, 03:37:01 AM »

I have no Idea what I'm doing. I understand some of that conf file.
It appears that some of the conf file has been lost from my post so I'd recommend following the link.

Mine works perfect and plays instantly now, so don't knock it.
Logged

Brandt
Newbie
*

Karma: 0
Posts: 38


View Profile
« Reply #7 on: January 17, 2011, 02:43:34 PM »

Ok well playing MP3's works find with either asound configuration I use, but my text to speech went back to being more crackled with a smaller buffer size.


Please try it:

Code:
apt-get install flite

flite -t "hello world, this is some very long text to see if the buffer size can handle a sentence of this."
Logged

Trune
Jr. Member
**

Karma: 3
Posts: 70


View Profile
« Reply #8 on: January 19, 2011, 03:06:10 PM »

same on mine unfortunately. goes bad towards the end of the sentence.
Logged

Pages: [1]
Print
Jump to: