• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,1)  (Read 5874 times)
« on: June 09, 2009, 06:12:26 AM »

Hi all !          (SOLVED)

I`ve been trying to install ubuntu on my external usb disk and now it seems my "skills" have caused a kernel panic on initial boot.

My goal is to install ubuntu on external usb disk as was instructed in here  http://www.computingplugs.com/index.php/Booting_entirely_off_an_external_USB_device#Edit_fstab_to_use_sda1 and http://www.cyrius.com/debian/kirkwood/sheevaplug/unpack.html

I flashed new kernel (2.6.30-rc8 new release) using the included README file, and if worked flawlessly. after this i partitioned usb disk to sd1 as root (ext3) and sda2 as swap.

Then i untarred lenny tarball to sda1 and made modifications to boot loader:

setenv mainlineLinux yes
setenv arcNumber 2097

setenv bootargs_root 'root=/dev/sda1 rootdelay=10'
setenv bootcmd_usb 'usb start; ext2load usb 0:1 0x0800000 /boot/uInitrd; ext2load usb 0:1 0x400000 /boot/uImage'
setenv bootcmd 'setenv bootargs $(console) $(bootargs_root); run bootcmd_usb; bootm 0x400000 0x0800000'
run bootcmd

After run bootcmd command, system seems to hang, --> reset button and boot again. If i dont interrupt the boot loader, i receive the following message at the end of the loading process

IP-Config: Complete:
     device=eth0, addr=, mask=, gw=,
     host=DB88FXX81, domain=, nis-domain=(none),
     bootserver=, rootserver=, rootpath=
List of all partitions:
1f00            1024 mtdblock0 (driver?)
1f01            4096 mtdblock1 (driver?)
1f02          519168 mtdblock2 (driver?)
No filesystem could mount root, tried:  ext3 ext2 ext4 cramfs vfat msdos jfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,1)
[<c00309c0>] (unwind_backtrace+0x0/0xe0) from [<c003db34>] (panic+0x50/0x120)
[<c003db34>] (panic+0x50/0x120) from [<c0008ec0>] (mount_block_root+0x1d4/0x214)
[<c0008ec0>] (mount_block_root+0x1d4/0x214) from [<c0009168>] (prepare_namespace+0x16c/0x1c4)
[<c0009168>] (prepare_namespace+0x16c/0x1c4) from [<c0008734>] (kernel_init+0xc0/0xec)
[<c0008734>] (kernel_init+0xc0/0xec) from [<c0040b28>] (do_exit+0x0/0x6ac)
eth0: link up, 100 Mb/s, full duplex, flow control disabled

What am i doing wrong here ? Yes, im quite new to linux...

I finally got my sheevaplug back up on its (rubber) feet, USB-recovery instructions helped a lot..

« Last Edit: June 09, 2009, 09:38:35 AM by sillis » Logged


Karma: 0
Posts: 1

View Profile
« Reply #1 on: October 06, 2009, 10:00:57 PM »

What you do to solve this problem?


Pages: [1]
Jump to: