• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: anyone tried mms stream in MPD successfully?  (Read 2268 times)
edwardwo
Newbie
*

Karma: 0
Posts: 5


View Profile
« on: November 22, 2010, 09:02:20 PM »

Hi, all:
My MPD play everthing OK, except mms stream. No matter I compiled manually(version 0.15.15) or use the binary from Debian Squeeze repo(version 0.15.12). The output just told me: "problem decoding mms", and I've definitely enabled the option "--enable-mms". I've compiled MPD on my laptop with the same options, mms stream is OK.
I even tried to use mplayer to play mms, and it's also OK. I'm totally lost, any ideas, thanks in advance.
Logged

Hell-G
Newbie
*

Karma: 2
Posts: 13


View Profile
« Reply #1 on: January 06, 2012, 11:33:11 AM »

Hi edwardwo

This is an old post, but I'm new to plug computers and maybe it is of help.

I compiled MPD version 0.16.6 from source on my D2plug running Ubuntu 10.04.3 LTS with a 2.6.32.9-dove-5.4.2 kernel. I was not satisfied with the included MPD version 0.15.4, as I had distorted mp3 playback. I included mms support and because of your post I tried two mms streams.

mms://stream.green.ch/argovia
gave me an error: "decoder_thread: mmsx_connect() failed". The same address works in mplayer. It takes quite long to get the connection in mplayer so maybe this is a timeout problem.

mms://apasf.apa.at/fm4_live_worldwide
works without problems in MPD and mplayer.

So I guess this version should work in general.

Logged

Pages: [1]
Print
Jump to: