• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: GuruPlug - Debian - DNS not working  (Read 7268 times)
rfryar
Newbie
*

Karma: 0
Posts: 6


View Profile
« on: November 20, 2010, 01:54:32 PM »

I followed the guide at http://discarded-ideas.org/guruconfig and have debian running from NAND.  However even setting up the gateway to my router (192.168.1.1) I can not access any external websites by ip nor can I resolve any DNS requests.

I can get around in Unix but am not familiar with how to configure the DNS.  I looked at the resolv.conf and it has 192.168.1.1 listed.  I double checked my network interfaces file to ensure I have the gateway properly listed with my static ip. 

I verified that the Guruplug can contact other computers on my network and those computers can see the plug, however the plug still is not correctly getting outside my LAN.

Any help would be appreciated.

Thanks,

Rick Fryar
Logged

two9er
Jr. Member
**

Karma: 10
Posts: 51


View Profile
« Reply #1 on: November 20, 2010, 02:46:38 PM »

Can you post the output of the following three commands and see if they resemble mine?
(adjusted for your ip's of course)

Code:
sheevaplug-debian:~# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:50:43:01:5f:e8
          inet addr:192.168.0.4  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2331862 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1238587 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2749947533 (2.5 GiB)  TX bytes:575129669 (548.4 MiB)
          Interrupt:11

eth1      Link encap:Ethernet  HWaddr 00:50:43:01:5f:e9
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:15

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:319156811 errors:0 dropped:0 overruns:0 frame:0
          TX packets:319156811 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1512842036 (1.4 GiB)  TX bytes:1512842036 (1.4 GiB)

sheevaplug-debian:~# cat /etc/resolv.conf
nameserver 192.168.0.1

sheevaplug-debian:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0

HTH, Jim
Logged

Just plugging away! GuruPlug Server Plus, 1TB esata hd, 8GB microSD (rfs)

rfryar
Newbie
*

Karma: 0
Posts: 6


View Profile
« Reply #2 on: November 20, 2010, 03:09:21 PM »

Here is my output.  I wonder if it is IPv6 that is causing it.  I run DD-WRT and I seem to remember some setting that is by default disabled for IPv6 support.  Any easy way to disable that on the GuruPlug if that is indeed the issue?

Code:
guruplug-debian:~# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 02:50:43:56:e5:c2
          inet addr:192.168.1.106  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::50:43ff:fe56:e5c2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43 errors:0 dropped:0 overruns:0 frame:0
          TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4492 (4.3 KiB)  TX bytes:7882 (7.6 KiB)
          Interrupt:11

eth1      Link encap:Ethernet  HWaddr 02:50:43:e9:70:f2
          inet addr:192.168.1.107  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:15

Logged

flashtek
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #3 on: November 21, 2010, 01:00:31 PM »

how about the output of 'cat /etc/resolv.conf' ?
Logged

rfryar
Newbie
*

Karma: 0
Posts: 6


View Profile
« Reply #4 on: November 21, 2010, 01:23:01 PM »

It just has one line.

Code:
nameserver 192.168.1.1

Oh and if I add the dns-server line to the interfaces file I can get outside the network with Pings and pings will resolve, but most other tools will still timeout.. Very strange.


Thanks,

Rick
Logged

birdman
Sr. Member
****

Karma: 4
Posts: 443


View Profile WWW
« Reply #5 on: November 22, 2010, 02:49:32 PM »

However even setting up the gateway to my router (192.168.1.1) I can not access any external websites by ip nor can I resolve any DNS requests.
Yet you say that you have set 192.168.1.1 as your DNS server, so you wouldn't need to have external access from the system to resolve a name.
Quote
I can get around in Unix but am not familiar with how to configure the DNS.  I looked at the resolv.conf and it has
192.168.1.1 listed.
Which is fine, provided your router is running a DNS server.  is it?  What happens if you run, say:
Code:
host 192.168.1.1 192.168.1.1
Does it respond instantly (possibly with an NXDOMAIN response) - in which case there is a server there, or does it hang for a while before reporting a connection time out - in which case there is no DNS server there,
Quote
I double checked my network interfaces file to ensure I have the gateway properly listed with my static ip.
But you haven't reported the output of "route -n" as requested, so we don't know that.
Quote
I verified that the Guruplug can contact other computers on my network and those computers can see the plug, however the plug still is not correctly getting outside my LAN.
Which definitely sounds like a default route problem.  So post the info.
Logged

rfryar
Newbie
*

Karma: 0
Posts: 6


View Profile
« Reply #6 on: November 22, 2010, 05:02:49 PM »

Well I resolved the issue but not sure why the original config did not work.

Here is how I fixed it.. Only the TOP ethernet port seems to correctly route, but it still does not get out until I switched eth0 to use DHCP.  At that point it was routing correctly and responding to DNS requests.  If I do not have anything in the eth0 port, eth1 does not correctly route.

But this is all academic now as while trying to update uboot my guruplug has bricked.  :0

Now comes the harder task of getting unbuntu in a virtual image so I can use JTag to recover (hopefully)  Ugg.

Thanks for the helpful in sights,

Rick
Logged

Pages: [1]
Print
Jump to: