• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Default environmental variables  (Read 1779 times)
jlpoole
Principal Software Engineer
Global Moderator
Jr. Member
*****

Karma: 2
Posts: 87

Principal Software Engineer -- Oracle Corporation


View Profile
« on: May 05, 2009, 06:02:46 PM »

For the record, I think the default environment of a newly born SheevaPlug ought to be posted for reference.

Here is what was on mine as of 8:37 p.m. (PDT), April 7, 2009:

Code:
Marvell>> printenv
baudrate=115200
loads_echo=0
ipaddr=10.4.50.165
serverip=10.4.50.5
rootpath=/mnt/ARM_FS/
netmask=255.255.255.0
console=console=ttyS0,115200 mtdparts=nand_mtd:0xc0000@0(uboot)ro,0x1ff00000@0x100000(root)
CASset=min
MALLOC_len=1
ethprime=egiga0
bootargs_root=root=/dev/nfs rw
bootargs_end=:::DB88FXX81:eth0:none
image_name=uImage
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x2000000;
ethmtu=1500
mvPhoneConfig=mv_phone_config=dev0:fxs,dev1:fxs
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
yuk_ethaddr=00:00:00:EE:51:81
nandEcc=1bit
netretry=no
rcvrip=169.254.100.100
loadaddr=0x02000000
autoload=no
ethact=egiga0
ethaddr=00:50:43:01:C1:36
run_diag=no
bootargs=console=ttyS0,115200 mtdparts=nand_mtd:0x400000@0x100000(uImage),0x1fb00000@0x500000(rootfs) rw root=/dev/mtdblock1 rw ip=10.4.50.4:10.4.50.5:10.4.50.5:255.255.255.0:DB88FXX81:eth0:none
bootcmd=nand read.e 0x800000 0x100000 0x400000; bootm 0x800000
stdin=serial
stdout=serial
stderr=serial
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
bootdelay=3
disaMvPnp=no
enaAutoRecovery=yes
arcNumber=2097
mainlineLinux=yes

Environment size: 1346/131068 bytes
Marvell>>
Logged

The statements and opinions expressed here are my own and do not necessarily represent those of Oracle Corporation.

mikekgr
Newbie
*

Karma: 0
Posts: 14


View Profile
« Reply #1 on: May 05, 2009, 11:03:47 PM »

Dear jlpoole,
I have two questions and I asking your kind help
1) is there any easy way to revert all u-boot setting to default (if I have change lot of things and seveenv then?)
2) How can re-activate the booting from nand flash the same way as I delivered the SheevaPlug to me?

Thanks a lot
Logged

Rabeeh Khoury
Administrator
Full Member
*****

Karma: 5
Posts: 218


View Profile
« Reply #2 on: May 06, 2009, 01:56:37 AM »

1. Yes. You can write 'resetenv' on the plug u-boot console and then 'reset' which will revert to u-boot default and then reset the board.
2. Refer to http://www.openplug.org/plugwiki/index.php/Factory_Default_u-Boot_Environment that explains how to revert the factory u-boot environment variables.
Logged

Pages: [1]
Print
Jump to: