• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Troubles with encoding  (Read 1442 times)

Karma: 0
Posts: 1

View Profile
« on: October 02, 2010, 08:39:25 AM »


I recently bought a SheevaPlug that I intent to use as a file server. I plugged in a USB hard drive and created an EXT2 file system on it. I transferred some files to the disk from Windows and mac using scp and an smb share. Everything was working perfect until I began storing files with danish special characters in the file name. The special characters appear as "?" when I do an "ls" in my shell.

I thought the problem was that the scp/smb clients were not writing the file names in UTF-8, but when I tried to create a file with a special character from my shell, the same thing happens. That is, I do the following:

henrik@debian:/mnt/lacie$ touch abc°
henrik@debian:/mnt/lacie$ ls

So it is writing the filename in a different encoding than the one it uses when listing the files? What am I missing here?

After spending some quality time on Google, I tried mounting the disk with the following entry in fstab:

/dev/sda1 /mnt/lacie ext2 defaults,iocharset=utf8 0 0

... which gives me the following error:

root@debian:~# mount /mnt/lacie/
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

I find no related messages in dmesg.

Thanks in advance for your help.


Pages: [1]
Jump to: