• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: NFS Root Filesystem Not Working  (Read 4497 times)
mteel
Newbie
*

Karma: 0
Posts: 10


View Profile
« on: April 08, 2009, 06:34:16 AM »

OK, received the sheevaPlug yesterday and immediately tried to get NFS root filesystem working. TFTP boot for the kernel image is working fine, but when the kernel tries to mount the NFS root filesystem, it fails with the following sequence:
Code:
Looking up port of RPC 100003/2 on 10.0.0.159
eth0: link up, full duplex, speed 100 Mbps
Looking up port of RPC 100005/1 on 10.0.0.159
VFS: Mounted root (nfs filesystem).
Freeing init memory: 104K
Warning: unable to open an initial console.
Failed to execute /bin/bash.  Attempting defaults...
Kernel panic - not syncing: No init found.  Try passing init= option to kernel.

I changed the kernel boot arguments to use /bin/bash after it kept failing with the default (should be /sbin/init) and specifying "init=/sbin/init".
It appears to mount but cannot access files in the root filesystem. This is the root filesystem provided with the SheevaPlug which is busybox-centric. The NFS server logs an authenticated mount from the SheevaPlug IP address, no errors.

I'm beginning to believe that the root filesystem provided is incomplete. It certainly is missing a console device in /dev.
Ideas?

Thanks,
Mark
Logged

mteel
Newbie
*

Karma: 0
Posts: 10


View Profile
« Reply #1 on: April 09, 2009, 08:04:35 AM »

After following the advice on a different post to untar the rootfs as root (using sudo), it works perfectly! I must have untarred the rootfs as my normal user then chown'd it to root before when it was not working.

Now onto building apps for the rootfs and perhaps creating a debian rootfs.
Logged

elBradford
Newbie
*

Karma: 0
Posts: 44


View Profile
« Reply #2 on: April 13, 2009, 11:54:25 AM »

I had this same problem. I eventually figured it out on my own, but yes, untar your rootfsv1.0 or whatever to the directory you're mounting as nfs. Works a charm too, just make sure to use the nfs exports settings given you in the documentation.
Logged

Brian
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #3 on: May 06, 2009, 11:13:46 AM »

...just make sure to use the nfs exports settings given you in the documentation.

Where might I find these settings for /etc/exports?  i'm having trouble finding the documentation.  Are these plug computer specific documents or the more generic nfsroot documents?
Logged

elBradford
Newbie
*

Karma: 0
Posts: 44


View Profile
« Reply #4 on: May 21, 2009, 12:41:14 PM »

You've probably figured it out by now, but you can download the docs from here: http://www.plugcomputer.org/index.php/us/resources/downloads?func=select&id=10

I am not sure which pdf it's in, but search for 'nfs exports' and you'll find it.
Logged

Pages: [1]
Print
Jump to: