• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Mono 2.6 on sheeva plug problems (running on ubuntu 9.04)  (Read 1242 times)
juanhawa
Newbie
*

Karma: 0
Posts: 3


View Profile
« on: September 10, 2010, 06:25:19 AM »

Hi there,

I'm trying to install apache2, mono 2.6 and all its friends (xsp, mod_mono, etc) from the sources. Though i succeeded in compiling everything, at run time i get the following error (as seen on the error_log of apache):

The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/local/lib/mono/1.0/mscorlib.dll' directory.

I looked for the file and its there, it has the right permissions and all.

And yes, i googled the thing, and i tried every solution i could found and nothing, nada.

Any help regarding this problem will be much appreciated Smiley

Thanks,
Juan Fernandez Hawa

Logged

birdman
Sr. Member
****

Karma: 4
Posts: 440


View Profile WWW
« Reply #1 on: September 10, 2010, 02:26:13 PM »

and i tried every solution i could found and nothing, nada.

Any help regarding this problem will be much appreciated Smiley
A short list of those solutions you've tried would help, otherwise we might just start suggesting the same things.

Have you told Apache where mono is?  Do you need to?

You could try starting up Apache with strace (might need the -D ? option to stop it daemonizing) and see whether it ever looks for mscorlib.dll.  There's a big difference between "not found" and "not usable".
Logged

Pages: [1]
Print
Jump to: