• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: SheevaPlug USB Recovery - WORKING now...  (Read 4558 times)

Karma: 1
Posts: 1

View Profile
« on: August 31, 2010, 11:18:28 AM »

To reflash a bricked SheevaPlug, these steps worked for me. Hope they help someone else...
Installing a Ubuntu distribution on a Sheevaplug (white)
Marvell and Globalscale give you a couple of methods of installing a distribution on a Sheevaplug. Unfortunately, on trying the procedures in
Sheevaplug development kit - USB Flash Recovery from U-Boot   Rev 1.2
Sheevaplug development kit - Writing Jaunty Filesystem on the NAND Flash   Rev 1.2
documents, they just do not seem to work!

On  plugcomputer.org web site there is a sheevaplug-installer-v1.0.tar.gz file. This is the basis to getting a working distribution downloader.
The tar file, as downloaded also does not work. A few changes need to be made to get it to work correctly. The procedure is in the README.txt file within the tar file. Changes needed are documented here.
1)Disregard the Windows installer steps: These just do not seem to work as advertised.. Just in case one needs to try these again, make the following changes to README.txt
In Host PC Pre-requisites:
After installing the pre-requisites, use the inf-wizard.exe in bin/86 to create inf files. Then install drivers in Windows by pointing to these inf files.
2)In the Linux pre-requisites, you may need to install openocd from the regular Ubuntu/Redhat or other repository
3)In runme.php comment out lines 7 & 8
/* find out if we run on Linux/Windows*/
/*if (strstr($_ENV["OS"], "Windows"))
4)Comment out lines 43, 44
    /*if ($_ENV["USER"] != 'root')
      die("You must run this as root\n");*/
5)This needs to be run as real root (sudo does not seem to work). If you need to enable root account on Ubuntu, in a shell run “sudo passwd root”, give a password, then “su” as root user.
6)Run “php ./runme.php nand”. The README.txt file does not talk of the options needed to run this php script.
The script will exit with an error at the end, but it actually does update the NAND on the Sheevaplug. Boot the plug, login as root/nosoup4u to confirm.


I am trying to reflash a (white) SheevaPlug with the stock kernel using the instructions in the "USB Flash Recovery from U-Boot Rev 1.2" document.
My USB stick has the flashware.img, uImage.sheeva.040309 & ubuntu-9.0.5.Release.jffs2 files on it.
From the U-boot prompt, I enter the loadaddr, mtd1Size and filesize params, saveenv and reset. From u-boot prompt, I type rcvr. The USB drive is found, and the kernel gets loaded, but then has a kernel panic saying that the ramdisk root fs is not found.

Also tried the tftp boot using the "Writing Jaunty filesystem on NAND flash - Rev 1.2" document. Kernel gets loaded fine, I can flash the nand, change u-boot params to boot feon nand. Seems to boot kernel from internal nand, but then kernel panics saying that no init found and try passing init= option to kernel. How do I do that?

Also tried the new plug-installer-v1.0 method. The readme is not in sync with the files provided, and I just didnt know how to resolve the differences.

Id really like to get the USB recovery procedure to work. Please let me know how if there are any ideas.
« Last Edit: September 23, 2010, 09:33:48 AM by oncam123 » Logged


Karma: 0
Posts: 31

View Profile WWW
« Reply #1 on: November 20, 2010, 12:50:28 AM »

Will try this out when I get the chance. Thanks in advance and hope it works for me too

Pages: [1]
Jump to: