• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Can't run wpa_supplicant on GuruPlug  (Read 1586 times)
rsalin
Newbie
*

Karma: 0
Posts: 15


View Profile
« on: July 07, 2010, 11:10:14 AM »

Hello
I just got a Guru Plug and now trying to get it to connect to the wifi. I managed to connect to it as a access point but I'm struggling to get it to access my wifi. The first problem was that there wasn't any wlan.sh file in the /root folder (according to http://www.plugcomputer.org/plugwiki/index.php/Setting_GuruPlug_to_be_a_WiFi_Client)... instead it was located in the /usr/bin directory... I run this, hopefully not causing any damage. I manage to scan for networks using iwlist and the one I'm hoping to connect to is found. (protected with wpa, switched it from wp2 as I wasn't sure if it'd work. if wpa2 work I'd appreciate instructions how to use it instead).

The issue is that when I'm trying to execute the command wpa_supplicant -i wlan0 -c my.conf -B (after creating the conf file) I get an error message saying that wpa_supplicant isn't found.

Also, if I try to install it via apt get I get the following errors:

sudo apt-get install wpasupplicant
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

After I ran the wlan.sh script it disabled the access point access (which I guess it should) so I'm now connected via ethernet.

I'd greatly appreciate some help! I'm really new to Linux and my skills are limited.

Best regards
Richard

ps. I've added a quite big heatsink to prevent the GP from overheating. So far it hasn't halted or rebooted though connected to a gb ethernet with wifi on. I did it straight away just to be sure as there was so much talk about the overheating so i can't say if it'd have been an issue. The sink gets quite hot though so most likely it would have.
« Last Edit: July 07, 2010, 12:18:52 PM by rsalin » Logged

Alucard
Newbie
*

Karma: 0
Posts: 10


View Profile
« Reply #1 on: July 08, 2010, 03:01:04 PM »

Have you run 'dpkg --configure -a' Huh
Logged

bananaplug
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #2 on: July 09, 2010, 12:57:41 PM »

I don't have a GuruPlug, but it seems running dpkg --configure -a would help, according to this guy. Hope that helps.

http://www.stevemilner.org/blog/2010/05/17/hello-guruplug-you-jerk/

Quote
As the error states, go ahead and run "dpkg --configure -a". Then edit /etc/apt/sources.list and comment out the silly internal to the manufacturers network IP address so the file looks like this:

deb http://ftp.us.debian.org/debian/ lenny main contrib non-free
deb http://http.us.debian.org/debian stable main contrib non-free
deb http://security.debian.org lenny/updates main contrib non-free
deb http://www.backports.org/debian lenny-backports main contrib non-free
#deb http://10.82.108.51/kedars/sheevaplug_wifi/builds/packages/ binary/

Logged

Pages: [1]
Print
Jump to: