• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: GuruPlug Ethernet Jumbo Frame problem  (Read 2395 times)
dreamdreams
Newbie
*

Karma: 0
Posts: 18


View Profile
« on: July 02, 2010, 05:57:21 PM »

I'm trying to test my plug's network performance and found its jumbo frame might have some issues.

I have two computers with Intel 82567LF and 82541PI gigabit NIC respectively. I tried them both with Guruplug, same problem, which is:
1. If I disable jumbo frame on both sides, everything is fine, iperf gets about 580Mbits/s one way and 660Mbits/s the other.
2. If I enable jumbo frame to 9000 on Intel side, I got almost same numbers.
3. If I change plug's mtu anything bigger than 1600(with Intel side mtu 9000), iperf doesn't go through. It connects though, just no traffic at all. This configuration also hangs NFS connection until I change plug's mtu back to 1500.
4. I hooked up my two computers, and set both sides to mtu 9000, iperf got 814 and 894Mbits/s two way.

The difference I observed is when two Intel NICs are hooked up, they both enables RX/TX flow control, well when plug and Intel NIC are hooked up, Intel NIC only enables RX flow control. Plug's NIC doesn't support flow control. ifconfig also shows that Intel NIC has some RX packets dropped, but not much(118 out of 3187126).

I also tried hook up them through a jumbo frame enabled switch, same results.

BTW, although iperf doesn't go, I can still do "ping -s 8000 -M do IPADDR" without problem which is strange.

Any idea?
Logged

Pages: [1]
Print
Jump to: