• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: MPD issues on the Guru  (Read 1745 times)
xxcn
Newbie
*

Karma: 0
Posts: 4


View Profile
« on: June 27, 2010, 03:17:02 AM »

Hi all,

I'm trying to use the GuruPlug as a jukebox. I got a cheap USB Sound Card dongle (since I'm still in the proof-of-concept phase), and audio playback works great with mocp/mp3blaster/aplay etc. However, MPD has glitches with audio playback -- it hogs the cpu, audio is interrupted every second or so. I suppose this is some resampling issue with mpd/alsa, but nothing suggested online helped.

Here's the relevant part of mpd.conf:

audio_output {
        type            "alsa"
        name            "Default Alsa"
        auto_resample   "no"
        use_mmap        "yes"
        device          "hw:0,0"        # optional
        format          "44100:16:2"
#       format          "48000:16:2"    # optional
#       mixer_device    "default"       # optional
#       mixer_control   "PCM"           # optional
#       mixer_index     "0"             # optional
}


and my asound.conf:



pcm.!default {
    type hw
    card 0
}

ctl.!default {
    type hw
    card 0
}

pcm.rawbluetooth {
        @args [ ADDRESS ]
        @args.ADDRESS {
                type string
        }
        type bluetooth
        device $ADDRESS
}

pcm.bluetooth {
        @args [ ADDRESS ]
        @args.ADDRESS {
                type string
        }
        type plug
        slave {
                pcm {
                        type bluetooth
                        device $ADDRESS
                }
        }
}


I also had to edit /etc/modprobe.d/alsa-base.conf and comment out the index setting for snd_usb_audio. This happens on the stock Debian distro, upgraded to testing.

Thanks!
Logged

chaotix
Newbie
*

Karma: 2
Posts: 11


View Profile
« Reply #1 on: June 27, 2010, 01:35:33 PM »

Mmmh. I have MPD working just fine. Ogg Vorbis and MP3 play without problems.

This is my audio_output section:

Code:
audio_output {
        type            "alsa"
        name            "U0xccd0x77"
        device          "hw:0,0"        # optional
}

My asound.conf also contains those bluetooth settings, but I don't have an entry for pcm.!default or ctl.!default.

Maybe it get's better when you remove the additional settings in mpd.conf and asound.conf.

Good luck,
Lars
Logged

Doug Grove
Newbie
*

Karma: 1
Posts: 19


View Profile
« Reply #2 on: June 30, 2010, 04:51:11 AM »

Well, my mpd on the sheeva with a USB sound device also works like a charm.  I use the minion plugin in firefox to control it.

My mpd.conf:

audio_output {
        type                    "alsa"
        name                    "USB Audio"
        device                  "hw:1,0"
        format                  "44100:16:2"
        use_mmap            "yes"
}

Note that I had to change the device.

So what version of mpd?

root@sheeva:/etc# mpd --version
mpd (MPD: Music Player Daemon) 0.15.9

Copyright (C) 2003-2007 Warren Dukes <warren.dukes@gmail.com>
Copyright (C) 2008 Max Kellermann <max@duempel.org>
This is free software; see the source for copying conditions.  There is NO
warranty; not even MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Supported decoders:

[mad] mp3 mp2
[oggflac] ogg oga
[flac] flac

Supported outputs:

null fifo alsa oss

Supported protocols:

file:// http:// lastfm://


High CPU usage was a known issue with some of the older MPDs.  I had to build mpd myself for a variety of reasons.  I'd be happy to post a tar ball if needed.

Hope that helps,

Doug
Logged

Kamikaze321
Newbie
*

Karma: 0
Posts: 19


View Profile
« Reply #3 on: August 18, 2010, 03:49:28 PM »

@xxcn

I had the same problems as you. having just "type" and "name" solved my problems. in your case try


audio_output {
        type                    "alsa"
        name                    "USB Audio"
#        device                  "hw:1,0"
#        format                  "44100:16:2"
#        use_mmap            "yes"
}

or something like that so you get only "type" and "name"
Logged

Pages: [1]
Print
Jump to: