• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Mounting eSATA Drive on boot  (Read 3652 times)
mandarine
Newbie
*

Karma: 0
Posts: 4


View Profile
« on: June 16, 2010, 11:26:24 AM »

Hello,

since yesterday I'm a proud owner of a black eSATA SheevaPlug with Debian 6.0 Squeeze on a 8GB SD Card. I'm able to mount the eSATA Drive when the Plug is up and running.

Now I've tried adding the following line to /etc/fstab:

/dev/sda1 /srv ext4 defaults,noatime 0 1

Now the Plug won't boot any longer. It stops with:

"Checking root file system ... fsck from util-linux-ng 2.16.2
Usage: fsck.ext4 ......

fsck died with exit status 16"

What went wrong? Is there any way to mount the eSATA Drive during boot time?

uboot Version is 3.4.16, Kernel is 2.6.32-7

Sascha
Logged

feffer
Jr. Member
**

Karma: -1
Posts: 56


View Profile
« Reply #1 on: June 16, 2010, 09:21:01 PM »

Not sure, but try this -- use uuid in fstab. First get the uuid designation of your esata hdd by attaching it to a booted machine. In linux you can use the command "blkid" or if that is not available
Code:
ls -l /dev/disk/by-uuid
Not sure how to do this in windows though.

Mount your SD card on your booted machine and open /etc/fstab with your editor (nano, vi etc) and change your line to something like this:
Code:
uuid=the-output-from-above /srv ext4 defaults,noatime 0 1
The older way to indicate a device, like "/dev/sda1" can be inconsistent, but the uuid is unique and can only mean that one device. Frankly, I'm not sure if this is the root of your problem, but it might be, and in any case, couldn't hurt.

Regards,
feffer
Logged

mandarine
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #2 on: June 16, 2010, 10:39:44 PM »

Hi feffer,

tried your tip, didn't work :-(

Any other suggestions?

Sascha
Logged

supert
Newbie
*

Karma: 0
Posts: 2


View Profile
« Reply #3 on: June 17, 2010, 11:21:52 AM »

I had a similar problem (also with esata sheevaplug) where the fsck of the root fs failed. It would run fsck.ext4 but the rootfs s ext3. So it would choke.
You don't specify which disk is failing so this might be your problem.
I 'fixed' it by adding a line in fstab mounting roots with 0 0 options at the end (copy the entry out of fstab).
I don't know why that should affect it, but it worked after that and I didn't do anything else.
Logged

mandarine
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #4 on: June 17, 2010, 01:07:21 PM »

I had a similar problem (also with esata sheevaplug) where the fsck of the root fs failed. It would run fsck.ext4 but the rootfs s ext3. So it would choke.
You don't specify which disk is failing so this might be your problem.
I 'fixed' it by adding a line in fstab mounting roots with 0 0 options at the end (copy the entry out of fstab).
I don't know why that should affect it, but it worked after that and I didn't do anything else.

here is the complete error message, I don't see which disk is failing
Code:
Usage: fsck.ext4 [-panyrcdfvtDFV] [-b superblock] [-B blocksize]
                [-I inode_buffer_blocks] [-P process_inode_size]
                [-l|-L bad_blocks_file] [-C fd] [-j external_journal]
                [-E extended-options] device

Emergency help:
 -p                   Automatic repair (no questions)
 -n                   Make no changes to the filesystem
 -y                   Assume "yes" to all questions
 -c                   Check for bad blocks and add them to the badblock list
 -f                   Force checking even if filesystem is marked clean
 -v                   Be verbose
 -b superblock        Use alternative superblock
 -B blocksize         Force blocksize when looking for superblock
 -j external_journal  Set location of the external journal
 -l bad_blocks_file   Add to badblocks list
 -L bad_blocks_file   Set badblocks list
fsck died with exit status 16

I tried it with:
Code:
/dev/sda1 /srv [b]auto[/b] defaults,noatime 0 1

and didn't get an error. Unfortunately the disk isn't mounted :-(

Can you please post your fstab? My initial fstab was emtpy, therefore I have no idea how you added the rootfs ...

Sascha
Logged

feffer
Jr. Member
**

Karma: -1
Posts: 56


View Profile
« Reply #5 on: June 20, 2010, 05:22:29 AM »

You could try:
Code:
/dev/sda1 /srv ext4 auto,defaults,noatime 0 1
Normally the "defaults" option should mount the partition, but since it's not, maybe the extra "auto" will force it. Also try putting the actual fs (ext4) rather than "auto"  might help and couldn't hurt. Also I noticed that you used a bold font on your "auto fs" entry. If that's what's actually in your fstab, it shouldn't be. Hope it helps.

And if it were me, I would use "uuid=xxxxx...." instead of /dev/sda1" but you already tried that  Wink

feffer
Logged

pietsnot
Newbie
*

Karma: 1
Posts: 41


View Profile
« Reply #6 on: June 21, 2010, 05:51:48 AM »

i had the exactly the same problem on my guruplug  with ext3-fs,  so i changed my fstab into:

/dev/sdb1               /                   ext3    defaults,noatime,errors=remount-ro 0 1 # mmc-sd
UUID=<UUID>        /mnt/sdc2     ext3    rw,noexec,nodev,async,noatime,nodiratime,data=writeback 0 1 # 2tb sata disk - 1tb partition

now i don't have the mentioned problem anymore

when you change the fstab-line at-the-end into   ...  0  0  , just to ignore the fsck,  it must work anyway
in your case:

/dev/sda1 /srv ext4 defaults,noatime 0 0 

« Last Edit: June 21, 2010, 06:07:21 AM by pietsnot » Logged

[unbricked]2xguruplug-server+2xjtag>nslu2;debian squeeze; [4|8]gb mmc:rootFS+swapFS; sata-hd 2tb; Linux-kernel-2.6.35.12; U-Boot_2010.03-01266; iptables:FW+router+gw;dhcpd;sshd;sabnzbd;vsftpd;exim4;rTorrent; nfs[d]; autofs; xorg; icewm; iceweasel; xrdp; privoxy+tor; apache; smbd; mediatomb>pch-a110

mandarine
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #7 on: June 21, 2010, 11:46:01 AM »

i had the exactly the same problem on my guruplug  with ext3-fs,  so i changed my fstab into:

/dev/sdb1               /                   ext3    defaults,noatime,errors=remount-ro 0 1 # mmc-sd
UUID=<UUID>        /mnt/sdc2     ext3    rw,noexec,nodev,async,noatime,nodiratime,data=writeback 0 1 # 2tb sata disk - 1tb partition

That sounds quite logical to me ... just one question: How did you know, that /dev/sdb1 is the SD-Card?

In the original configuration, my /etc/fstab is empty, so the SD is mounted in another way (which I don't know) ...

Any suggestions?

Sascha
Logged

pietsnot
Newbie
*

Karma: 1
Posts: 41


View Profile
« Reply #8 on: June 21, 2010, 02:34:31 PM »

i had the exactly the same problem on my guruplug  with ext3-fs,  so i changed my fstab into:

/dev/sdb1               /                   ext3    defaults,noatime,errors=remount-ro 0 1 # mmc-sd
UUID=<UUID>        /mnt/sdc2     ext3    rw,noexec,nodev,async,noatime,nodiratime,data=writeback 0 1 # 2tb sata disk - 1tb partition

That sounds quite logical to me ... just one question: How did you know, that /dev/sdb1 is the SD-Card?

In the original configuration, my /etc/fstab is empty, so the SD is mounted in another way (which I don't know) ...

Any suggestions?

Sascha
i had to flash a new u-boot: U-Boot 2010.03-01161-gd91b0a9 (Apr 22 2010 - 03:24:41)
urls:
http://oinkzwurgl.org/guruplug_uboot
http://plugcomputer.org/plugforum/index.php?topic=1642

so had to change u-boot envs in order to boot from mmc-sd:

u-boot, printenv:
   x_bootargs_root=root=/dev/sdb1 rootdelay=13
   bootcmd=${x_bootcmd_usb}; ${x_bootcmd_kernel}; setenv bootargs ${x_bootargs} ${x_bootargs_root}; bootm 0x6400000;

so:  /dev/sdb1 is the rootFS
« Last Edit: June 21, 2010, 03:19:31 PM by pietsnot » Logged

[unbricked]2xguruplug-server+2xjtag>nslu2;debian squeeze; [4|8]gb mmc:rootFS+swapFS; sata-hd 2tb; Linux-kernel-2.6.35.12; U-Boot_2010.03-01266; iptables:FW+router+gw;dhcpd;sshd;sabnzbd;vsftpd;exim4;rTorrent; nfs[d]; autofs; xorg; icewm; iceweasel; xrdp; privoxy+tor; apache; smbd; mediatomb>pch-a110

supert
Newbie
*

Karma: 0
Posts: 2


View Profile
« Reply #9 on: July 27, 2010, 02:47:37 PM »

As requested:
Code:
root@sheeva:~# cat /etc/fstab
rootfs / rootfs rw,relatime 0 0
LABEL=/data /mnt/share ext4 defaults,rw,users,relatime 1 2
LABEL=/var /var ext4 defaults 1 2
/dev/sda3 swap swap defaults 0 0

root@sheeva:~# cat /etc/mtab
rootfs / rootfs rw,relatime 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid,mode=0755 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
udev /dev tmpfs rw,mode=0755 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=620 0 0
/dev/sda1 /mnt/share ext4 rw,noexec,nosuid,nodev 0 0
/dev/sda2 /var ext4 rw 0 0
Logged

nancy-johnson
Guest
« Reply #10 on: August 13, 2010, 10:25:39 PM »

Same problem what to do??
Logged

Blüto
Newbie
*

Karma: 5
Posts: 38


View Profile
« Reply #11 on: August 15, 2010, 06:05:38 AM »

I'm a proud owner of a black eSATA SheevaPlug with Debian 6.0 Squeeze on a 8GB SD Card.

Same problem what to do??

First, you should seek assistance with this problem from NewIT. eSATA SheevaPlugs are hard to come by in the U.S., but even if they weren't, we can only speculate about the layout of the card, the contents of your u-Boot environment and what changes may have been made to the 6.0 (unstable) branch of Debian since the SD card was manufactured.
Logged

Pages: [1]
Print
Jump to: