• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: I can't load wifi driver  (Read 3012 times)
djraffon
Newbie
*

Karma: 0
Posts: 5


View Profile
« on: June 14, 2010, 05:10:51 PM »

First of all I ve installed Debian Squeeze on my Sheevaplug using the ShevaPlug Installer.
Then I have updated the kernel to the 2.6.32.5 using http://sheeva.with-linux.com/sheeva/README-2.6.32.5

in order to compile the driver on the plug I installed the packages "build-essential" and "linux-headers-2.6.32-5-all" via aptitude on the plug.

because the links "build" & "source" were bad  in /lib/modules/2.6.32.5/, I ve done
rm /lib/modules/2.6.32.5/build
rm /lib/modules/2.6.32.5/source
ln -s /usr/src/linux-headers-2.6.32-5-kirkwood/ /lib/modules/2.6.32.5/build
ln -s /usr/src/linux-headers-2.6.32-5-common/ /lib/modules/2.6.32.5/source

the compilation of the driver is fine on the sheevaplug but when I try to use it with:
insmod rt2870sta.ko

I have an error:
insmod: error inserting 'rt2870sta.ko': -1 Invalid module format

I don't understand why the module format is wrong and I don't have any idea why I have it.

If someone have any idea for helping it would be nice.
Logged

ppmt
Full Member
***

Karma: 1
Posts: 129


View Profile
« Reply #1 on: June 14, 2010, 05:35:38 PM »

try to do

Code:
modinfo rt2870sta.ko

the line about vermagic should be the same as the result of:

Code:
uname -a

if it is not that is why is fails

you can verify it by forcing the vermagic

Code:
modprobe --force-vermagic rt2870sta.ko

note that I know this because I ran into similar problem but haven't rally been able to fix it reliably Sad
Logged

djraffon
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #2 on: June 15, 2010, 07:01:02 AM »

Hi and thanks for the help,

the command "modinfo rt2870sta.ko |grep vermagic" answer me:
vermagic:       2.6.32-5-kirkwood mod_unload modversions ARMv5

and the command "uname -r" answer me:
2.6.32.5

so maybe the solution is tu use the linux-headers from http://sheeva.with-linux.com but when I download them and untar the tarball I get a "usr" folder with inside a "include" folder with 10 other folders inside like "asm", asm-generic", "drm", "linux", "mtd", ...
and I don't know what to do with this "usr" folder, I don't know where to copy it, and there is no README.txt inside the tarball.

Well maybe I should add a new topic on this forum for "How to use headers from sheeva.with-linux.com"


Logged

ppmt
Full Member
***

Karma: 1
Posts: 129


View Profile
« Reply #3 on: June 15, 2010, 07:03:46 AM »

well this is where my competence stops..

I am also trying to play around with my guruplug trying to update and I keep hitting issues like that or compilation that fails.....I just can't understand it Sad

I got some great help on the freenode irc channel (#openplug) may be you can try there
Logged

birdman
Sr. Member
****

Karma: 4
Posts: 443


View Profile WWW
« Reply #4 on: June 15, 2010, 05:04:49 PM »

the command "modinfo rt2870sta.ko |grep vermagic" answer me:
vermagic:       2.6.32-5-kirkwood mod_unload modversions ARMv5
Have a look at the Makefile in source.  If EXTRAVERSION is set to be "-5-kirkwoood" then set it to be ".5" instead.
Also look at include/linux/utsrelease.h and see what UTS_RELEASE is set to.  That should be "2.6.32.5".  It's possible this gets set at boot time, though, so if you change it - check it sticks.
Logged

panachoi
Newbie
*

Karma: 0
Posts: 9


View Profile
« Reply #5 on: July 01, 2010, 10:54:57 PM »

I've been hitting this also. I've actually downloaded and unpacked a "virgin" source (2.6.34), applied the Marvell Kirkwood patches, and then built a kernel and modules (I cross compiled;  I dont think that matters, but maybe it does). Everything appeared to go fine, and I can boot (via TFTP/NFS) the kernel, but it seems pretty unhappy with all of the modules, because on each and every module load it spits out:

2.6.34 mod_unload modversions ARMv5 ' should be '2.6.34 preempt mod_unload ARMv5

Granted, uname -a returns:

Linux guruplug 2.6.34 #1 PREEMPT Thu Jul 1 09:47:26 CEST 2010 armv5tel GNU/Linux

I started out with a virgin kernel source, and there is no LOCALVERSION defined in the kernel configuration, so something is being done without our knowledge!

Logged

birdman
Sr. Member
****

Karma: 4
Posts: 443


View Profile WWW
« Reply #6 on: July 02, 2010, 05:23:07 PM »

I started out with a virgin kernel source, and there is no LOCALVERSION defined in the kernel configuration, so something is being done without our knowledge!
I take it you mean EXTRAVERSION?
Note that almost all of the kernel code changes are, I suspect, done without your "knowledge".
However, that variable is usually set when some vendor makes a build for distribution, which is why a virgin kernel source has it empty.  I suspect it's there to denote what options were set in the config.  Nothing more sinister than that.
Logged

Pages: [1]
Print
Jump to: