• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: [RESOLVED] SdCard speed probleme with automount (Guru+)  (Read 2340 times)
Mimoza
Newbie
*

Karma: 0
Posts: 16



View Profile
« on: June 08, 2010, 11:26:32 AM »

Hi.
The original problem was here
But i found exactly when the problem appear, so i open a new topic to find a solution.

Well i try to put the rootfs on a SD card.
I bough a Dan-Elec 8Go class4 microSDcard and i test his performance.
And surprise the write speed is around 9Ko/s  Shocked and read speed around 20Mo/s  Smiley
I tried many things to find the probleme, and finnaly i reformate the SD card from my plug and when i mount the new partition it's works fine  Grin
But when i get out / in the SD card from the plug the problem reappear  Angry
So there two case:
-- The SD card is auto mounted by the system = speed problem
-- The SD card is manually mounted by user = works fine

Finally when i boot the rootfs on sdcard the system is very slow  Cry

Any idea / suggestion ?

Thx

edit : I don't flash Uboot and Kernel ...
U-Boot =  2009.11-rc1-00602-g28a9c08-dirty
Kernel =  2.6.32-00007-g56678ec
« Last Edit: June 12, 2010, 03:42:01 PM by Mimoza » Logged

chaotix
Newbie
*

Karma: 2
Posts: 11


View Profile
« Reply #1 on: June 08, 2010, 07:07:23 PM »

What options for the filesystems are in use when you mount it manually or the system mounts it?

You can check the options with cat /proc/mounts
Logged

Mimoza
Newbie
*

Karma: 0
Posts: 16



View Profile
« Reply #2 on: June 12, 2010, 05:15:25 AM »

sorry for delay.
I don't use any option when i mount manually the card just an
Code:
mount /dev/sdb1 /media/usb0

My /proc/mounts looks like that
Code:
rootfs / rootfs rw 0 0
ubi0:rootfs / ubifs rw,relatime 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid,relatime,mode=755 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
usbfs /proc/bus/usb usbfs rw,nosuid,nodev,noexec,relatime 0 0
tmpfs /dev tmpfs rw,relatime,size=10240k,mode=755 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
tmpfs /var/cache/apt tmpfs rw,nosuid,noexec,relatime 0 0
/dev/sdb1 /media/usb0 ext3 rw,sync,nodev,noexec,noatime,errors=continue,data=writeback 0 0

When the card is mounted automaticaly i have
Code:
sheevaplug-debian:~# mount
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
rootfs on / type rootfs (rw)
tmpfs on /var/cache/apt type tmpfs (rw,noexec,nosuid)
/dev/sdb1 on /media/usb0 type ext3 (rw,noexec,nodev,sync,noatime)

and manually :
Code:
...
/dev/sdb1 on /media/usb0 type ext3 (rw)

So when i mount manually with options
Code:
mount /dev/sdb1 /media/usb0 -o noexec,nodev,noatime, sync # same speed problem
mount /dev/sdb1 /media/usb0 -o noexec,nodev,noatime         # no problem

Now How can i delete the "sync" option by default Huh

« Last Edit: June 12, 2010, 05:38:12 AM by Mimoza » Logged

fragfutter
Sr. Member
****

Karma: 12
Posts: 280


View Profile
« Reply #3 on: June 12, 2010, 06:07:22 AM »

you place it with the right options in fstab.

Code:
/dev/sdb1     /media/usb0   ext3 auto,relatime,noexec,noatime,async  0 0

LABEL instead of the devicename might be better. I think the gurplug sometimes shuffles sd devices around depending what is attached at boot time.

Logged

Mimoza
Newbie
*

Karma: 0
Posts: 16



View Profile
« Reply #4 on: June 12, 2010, 12:42:28 PM »

Well, but if i want make the sdcard my rootfs, it's work ?

edit :
I found a generic solution for all usb
There a daemon an we can change option in /etc/usbmount/usbmount.conf

edit :
It's seems working with sdcard as fsroot  Cheesy
So i tag RESOLVED
« Last Edit: June 12, 2010, 03:41:42 PM by Mimoza » Logged

Pages: [1]
Print
Jump to: