• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: update-initramfs error on Debian SID  (Read 2278 times)
Xile
Newbie
*

Karma: 0
Posts: 2


View Profile
« on: June 01, 2010, 04:28:36 AM »

Hi,

I've followed the instructions to install Debian SID on my GuruPlug Server Plus to sd card posted in this howto:
http://bzed.de//posts/2010/05/installing_debian_on_the_guruplug_server_plus/

During the installation the errors mentioned in the howto appear (e.g. Make Installation bootable, etc) ... according to the howto i copied the kernel files to internal nand flash and configured the U-Boot to load kernel files from nand. Everything went fine but when i try to install the first package via apt-get install (e.g. Samba) i got an error :

Quote
tarting Samba daemons: nmbd smbd.
Setting up samba-common-bin (2:3.4.8~dfsg-1) ...
update-alternatives: using /usr/bin/nmblookup.samba3 to provide /usr/bin/nmblookup (nmblookup) in auto mode.
update-alternatives: using /usr/bin/net.samba3 to provide /usr/bin/net (net) in auto mode.
update-alternatives: using /usr/bin/testparm.samba3 to provide /usr/bin/testparm (testparm) in auto mode.
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-5-kirkwood
Generating kernel u-boot image... /usr/sbin/flash-kernel: 476: mkimage: not found
dpkg: error processing initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 127
Errors were encountered while processing:
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

Nevertheless the installed packages work fine...
How can i solve this error of update-initramfs ? Or can i just ignore ist ?

Thx 4 your help !!
Logged

pancho
Newbie
*

Karma: 1
Posts: 20


View Profile
« Reply #1 on: June 01, 2010, 07:52:18 AM »

Hi there.

It seems that the binary ‘mkimage’ is missing.

Quote
Generating kernel u-boot image... /usr/sbin/flash-kernel: 476: mkimage: not found

Try installing it:

Code:
# aptitude install uboot-mkimage

Hope that it helps.

Happy hacking!
« Last Edit: June 01, 2010, 08:12:05 AM by pancho » Logged

Xile
Newbie
*

Karma: 0
Posts: 2


View Profile
« Reply #2 on: June 01, 2010, 12:26:03 PM »

Thx a lot, that solved my problem !
Logged

Pages: [1]
Print
Jump to: