• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Guruplug network slow?  (Read 2023 times)
Yrch
Newbie
*

Karma: 0
Posts: 3


View Profile
« on: May 28, 2010, 02:54:24 AM »

Ok. Now I was able to test this with onother computer. The guruplug was definitly not the problem.

Hi, I have a guruplug server plus, plugged two ethernet cables in. Both at 100Mbits.
I recogniced sending files over to the plug is something slow, so I measured the speed of the connection. What I did is:

This is sending data from computer to plug:
Code:
myplug# netcat -l -p 12345 >/dev/null
Code:
mycomputer# netcat myplug  12345 -c "dd if=/dev/zero count=10000"
10000+0 Datensätze ein
10000+0 Datensätze aus
5120000 Bytes (5,1 MB) kopiert, 12,6162 s, 406 kB/s

This is sending data from plug to computer:
Code:
mycomputer# netcat -l -p 12345 >/dev/null
Code:
myplug# netcat mycomputer  12345 -c "dd if=/dev/zero count=10000"
10000+0 Datensätze ein
10000+0 Datensätze aus
5120000 Bytes (5,1 MB) kopiert, 0,420065 s, 12,2 MB/s

So, 12,2 MB/s (plug->computer) seems normal. But 406 kB/s (computer->plug) is far too slow.
The question now is:
What causes this slowness? Is it because of the plug/ethernet driver, or is it caused by other hardware in my network?
Could someone of you please repeat this measurement and post the result and configuration (10/100/1000 Mbit? 1 or 2 cables plugged in?) here?

Something also useful:
Code:
myplug# uname -a
Linux nomainframe4u 2.6.33.2-00003-g4b82fc0 #1 PREEMPT Thu Apr 22 03:29:35 PDT 2010 armv5tel GNU/Linux
myplug# grep "link up" /var/log/messages | tail -n 2
May 27 16:52:20 nomainframe4u kernel: eth0: link up, 100 Mb/s, full duplex, flow control disabled
May 27 16:52:21 nomainframe4u kernel: eth1: link up, 100 Mb/s, full duplex, flow control disabled

« Last Edit: May 28, 2010, 07:46:22 AM by Yrch » Logged

popon
Newbie
*

Karma: 3
Posts: 24


View Profile
« Reply #1 on: May 28, 2010, 03:49:02 PM »

I also noticed this fact.
I  connect my guruplug server+ to a 100M router.
Everything is very slow. Even the ping, e.g., ping www.yahoo.com, the response
is very, very slow.
My sheevaPlug coneects to the same router, but its response is very fast.
Logged

popon
Newbie
*

Karma: 3
Posts: 24


View Profile
« Reply #2 on: May 28, 2010, 09:34:18 PM »

I found out my problem.
My network is with 192.168.1.0/24 , however the  nameserver in
/etc/resolv.conf is set to be 192.168.0.1.
After revising the value of the nameserver, it becomes fast.
Logged

Yrch
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #3 on: May 31, 2010, 04:34:38 AM »

I found out my prooblem too:
It was a loose connection of the cable to my computer.
Logged

Pages: [1]
Print
Jump to: