• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Sheeva Install problems  (Read 2744 times)
lloverin
Newbie
*

Karma: 0
Posts: 11


View Profile
« on: May 21, 2010, 01:07:14 PM »

I had a sheevaplug with an MMC card as the root file system and everything was fine until the mmc card broke when something fell on it.  I tried to change the uboot back to the internal file system but got magic number errors.  I decided to try the sheeva installer here on the wiki.

Well, I tried it from Windows (Windows 7), Windows XP (in a VM), and Ubuntu (in a vm).  I'm cabled directly to the plug, and have installed all FTDI drivers and the libusb-win32 set.

The problem begins after I run (in Windows) 'runme nand' which loads the screen with the beginning of the script and ends with the FTDI can't be found.

In ubuntu, I log in as root and try to run the PHP scripts with 'php runme.php nand' and it tells me I have to be root.  I AM ROOT!  I also try from an account and use Sudo,  and it says You Must Use Root.

I'm at wits end.  The plug is bricked and needs a full install.

-Larry
Logged

rooster
Administrator
Sr. Member
*****

Karma: 8
Posts: 311


View Profile
« Reply #1 on: May 21, 2010, 08:50:28 PM »

Try out the new QT installer http://sourceforge.net/projects/esia/
Logged

Deviant0ne
Newbie
*

Karma: 0
Posts: 30



View Profile
« Reply #2 on: May 22, 2010, 11:51:21 AM »

The QT installer works really well with Windows, but it can be a little bit of a pain to set up. When it's set up though, it's really nice.

On a side note, have you tried running the PHP file as root and using sudo? Just a thought...
Logged

lloverin
Newbie
*

Karma: 0
Posts: 11


View Profile
« Reply #3 on: May 24, 2010, 04:07:34 PM »

The QT installer works really well with Windows, but it can be a little bit of a pain to set up. When it's set up though, it's really nice.

On a side note, have you tried running the PHP file as root and using sudo? Just a thought...

I did run the php as root and using sudo on the other account.  I'm going to try using QT with XP.
Logged

truehl
Newbie
*

Karma: 0
Posts: 23


View Profile
« Reply #4 on: May 27, 2010, 01:02:54 PM »

I'm at wits end.  The plug is bricked and needs a full install.
Larry: Please take a look here: http://wiki.slimdevices.com/index.php/SqueezePlug#SqueezePlugRescue-System
Logged

marcus
Jr. Member
**

Karma: 5
Posts: 83


View Profile
« Reply #5 on: May 28, 2010, 12:35:47 PM »

In ubuntu, I log in as root and try to run the PHP scripts with 'php runme.php nand' and it tells me I have to be root.  I AM ROOT!  I also try from an account and use Sudo,  and it says You Must Use Root.

Newest version of Ubuntu does this. Probably a change to PHP. You can hack the runme.php script to remove that particular test.
Logged

Pages: [1]
Print
Jump to: